CSW V2.5/ USB Issue

I have a really strange issue with my wheelbase and hope someone can help.

Since owning the 2.5 from new, I was disappointed and thought it would be better. I tried every driver and whilst there were small changes, it still never felt right.

I tried every solution i could think off, even clean install of windows but nothing worked, until today.

Tonight I uninstalled all USB controllers in device manager, force closed my pc as it stopped my mouse working of course. The rebooted, turned on the wheel and tried it. The feeling was incredible. It was what i hoped for and more when i bought the base. The front end feel was incredible, every little detail. Whilst pulling out of the pits in ACC the FFB was so heavy, then under acceleration it got lighter and that variance stayed throughout my tests. I was gobsmacked.

This is where it gets strange.

I then opened the Fanatec control panel to check my settings and all was as before.

I then tried ACC again and it was back to how it was before. Terrible.

I've now had to repeat the procedure of uninstalling all USB controllers to get it working correctly again (and won't be opening it again until I understand exactly how to fix it properly).

Does anyone have any idea what is happening, and maybe how to fix.

FYI:

Windows 10 64 bit

Yes, all drivers, including USB and chipset are up to date

Thank you in advance

Comments

  • Ah so I'm not going mental! I've had this a couple of times too, though I haven't had to uninstall usb controllers. Although on today's session I could not get rid of the heavy feeling, I just had to lower the ffb. I don't really play much else so have only experienced this in ACC.

    CSW 2.5

    Driver Number: 328

    Wheel Base Firmware: 628

    Wheel Base Motor Firmware: 22

    Plugged into powered usb hub, using usb 2

    Windows 10

  • edited August 27

    I have had the same , what i found is you have to power up the wheel and pc in a specific order.

    For me i always make sure the wheelbase has fully powered up and finished it's self test (wheel rotating) and then i power on my PC , but if i power the wheel after windows is running i don't always get the same FFB.


    Sometimes if i didn't do it in the correct order i would have to completely power down PC and wheelbase and go through my start up sequence again to get the FFB working properly


    This was most obvious on Iracing as i would loose most of the wheel weight when turning , sometimes i could get it back by turning of the wheelbase and on again but most of the time i would have to do the PC complete power cycle to get it back to normal.


    Powering the Wheelbase first then PC always works for me.

  • Not sure exactly what did it but now seems to be fully fixed.

    I uninstalled every usb device/ driver and also re-installed USB drivers. Working perfectly now and ffb feels great.

    Thanks for the replies/ advice too.

Sign In or Register to comment.