DD1 initial set up issues and cannot raise support issues...

Hi all, hopefully someone can help.

I attempted to raise a tech support issue several days ago but the form deletes the comments and subject whenever I select submit (tried multiple browsers, 2 PC's and my mobile phone which can't even log in to Fanatec Au).

I emailed Fanatec on the email address they used to communicate with me about a cross threaded bolt on my pedals and haven't had a response...

So I purchased a DD1 ages ago and haven't had a chance to set it up until now due to work and waiting on parts for a new rig - I now finally have the new rig built to fit it...

First I downloaded The highest non beta driver on the website, it seemed to work (I could get up to the part where you can test each button/calibrate the motor etc.) but after I updated to the latest driver as per it's recommendation and restarted windows it was not showing up in game controllers anymore...

I have since tried with newer drivers from the forums as per some advice (such as the recent Boosted Media YouTube video about how to install Fanatec drivers) and it never seems to take.

In between each attempt I always go to add/remove programs to uninstall and restart first.

I also tried fresh without windows defender/firewall on and did the latest feature update of win10 first as well. Running out of ideas and patience, I would really appreciate any insight.

I'm dreading having to send the wheel back now I finally have some spare time...

Some notes: base is always in PC mode but sometimes only shows the Fanatec logo.

Power button on base will not turn it off

about 10% of attempts when turning it back on I would get the hi torque warning.

I have tried with and without the Porsche Podium wheel attached.

64bit Drivers tried: 335, 342, 356, 373

I have also tried to update driver in windows device manager following the troubleshooting part of the PDF. after the restart it still is not in game controllers (after selecting the fanatec app) so I went to do it a second time as per troubleshooter and the usb device is still flagged as not recognised but I cannot update it as windows says its drivers are up to date...

Any help would be greatly appreciated!


  • update:

    with 0 drivers/fanatec software installed the wheel base will show the USB/PC and wheel icon (with wheel installed) above the fanatec logo. Windows pop up said successfully installed.

    I went to game conrollers and could open either of the two lines for the DD1 and it displayed the windows set up with different axis and buttons, none responded to button pushes or wheel movement (porsche podium display is blank).

    From that point installing the 346 or 373 drivers makes the wheel base disappear from game controller after the restart. Also tried installing from Device Manager again, no difference.

    uninstalled the drivers but now I cannot get the wheelbase to do that again, just the fanatec logo showing only now...

  • Did you get it sorted?

Sign In or Register to comment.