CSL Elite won't complete startup

Hi,

Looking for some help and advise. I was playing the other night and in the middle of a race the wheel errored out. The mapping got screwed up and started putting inputs in the wrong place, (Gas pedal to downshift, Break to look to the side) weird things.

I rebooted the wheel and it wouldn't complete the startup: wheel would spin to left and right but the rev lights would not finish their part of the start up sequence.

I attempted to get into boot mode, which worked but received the following:

Anyone know what the next steps are?

Thanks

R. Ausman

Comments

  • edited August 24

    Have you tried removing the rim and then power up the base only? I have had issues like this with my CSL Elite 1.1 If I remove the rim and power up it goes fine, then I put the rim back on and power up again and it’s all good again.

    Remember to always post when firmwares and drivers you have installed also.

  • Tried it out same as before; both on Xbox and PC. Last check for firmware updates in late-June or early-July 2020. I can't get the to bootloader to determine any drivers or versions. Primarily use the wheel on Xbox.

Sign In or Register to comment.