Has anybody with a Podium DD wheel had wheels not recognized by the wheel base or control panel?

I tried to use my wheel the other day and there is no LEDs, no response what soever from any wheel. I have both the Formula V2 wheel and the McLaren wheel and in the control panel and Fanalab the wheels are blanked out. On the control panel the wheel driver isn't even there anymore!

I have tried to uninstall all the drivers, reinstalled them and still not wheels are recognized as being on the wheel base.

Do the Podiums only have a life span of 12 months? I've only had it for 10 months, using it 2 hours a day?

Any solutions would be appreciated, otherwise I'll just have to send the Wheel base back unfortunately under warranty for replacement.

Comments

  • Have you made sure the wheel is fully on and connected? Some wheels might need a bit more force. I’m assuming both of your wheel FW have been updated?

  • Thanks for responding Joseph. Yes, have tried to make sure enough force and well connected. As far as FW updates, I have the Formula V2 wheel and try to install the FW, but it keeps stating a more recent one is already installed, but it isn't. Wheel firmware isn't even shown on the Fanatec control panel.

    I'm thinking maybe the DD1 wheel base has had it.

  • Can you try installing Driver 356 to see if that helps.

  • Yep, 356 is installed. Have the following showing in the Fanatec Control Panel:

    PC Driver: 356

    Wheel Base Firmware: 670

    Wheel Base Motor Firmware: 38

    As you can see, no wheel firmware can be loaded.

    In Fanalab the steering wheel is blocked out .

    Maybe it's a Windows update issue?

  • My problem is similar

  • So Todd, you can't use your wheel either?

    I'm waiting to talk to Fanatec. I noticed they don't have a phone number listed anymore, only email support!

  • I have the similiar problem.

    PC Driver: 356

    Wheel Base Firmware: 670

    Wheel Base Motor Firmware: 38

    Steering Wheel Firmware: 2

    For some reason, the software is not recognizing the Podium Button Module Endurance that I have installed.

  • I can't even load Steering Wheel Firmware for some reason, and the silly Fanatec Control Panel advises I have the latest drivers when i try to update!

    So what did you do to fix it?

  • My DD1 PS4 base has the same issue, the wheel lost connection to the base after upgrading to v356 and the firmware, to get ready for the Porsche Podium wheel. I sent it back, the main cord was exchanged and it came back with driver v347. Upgrade to v356, lost force feedback, downgraded to v335, lost connection between base and wheel, upgraded to v347 didn'nt fix it. It's now going back on an RMA at the Fanatec workshop for the second time.

  • Yep, frustrating and this is the problem - the Fanatec firmware is unstable and unreliable.

  • I'm happy to announce that Fanatec replaced my DD1 PS4 base after my latest RMA was initiated. I asked them by email what they found to be the root cause, what they did to fix it, if it would be compatible with driver v356 and the associated firmwares and which versions I could expect to be installed when I received the unit again. I am still waiting for a reply to that email.

  • It takes forever Jacob. My DD1 was sent back RMA over a week ago, so now I have been without a wheel and base for 3 weeks, so by the time it's returned it will be a month without racing! I think it's the unstable firmware to blame.

    I may have to look at Simucube Pro 2 or Simagic for my next direct drive wheels, as they may be more reliable and better service. I've looked at many reviews over the downtime and they are very positive for both!

  • I got an answer from support "Our technicians found out the wheel base was the root cause of the problems. There is an issue with the motor or the motor FW. The deeper analysis is still ongoing." I am so happy they sent me a new base, it works perfectly now. I am still very afraid to do the v356 upgrade in case it "burns" the base again but they have assured me that I shouldn't have any problems upgrading the firmware. I asked if my problems with the first base had anything to do with the batch it came from but the answer was that all versions/batches should be compatible with the latest firmware. I still think I will wait to do the firmware upgrade until the new driver/firmware is released in March and we have seen some user feedback.

Sign In or Register to comment.