New dd1 inop after v356 motor update

Hi! I am so excited about my new products i received a few days ago. Podium DD1, Podium hub, BME with porsche gt3 leather wheel.

As soon as i update the dd1 motor firmware, the base is unrecognizable and is stuck. Led on base shows fanatec but no connections. The BME is dead.

I went to update per instructions to v356 firmware. I have spent hours trying to get this to work. I updated dd1 base, dd1 motor, phub to v2, and bme. If i update the base firware first the BME works and all buttons and leds test okay in UI. But the fan on base is at 100% and it doesnt recognize any steering wheel rotation. No matter what order i do any update, the end result is flashing v356 firmware to dd1 motor makes assembly unrecognizable.

I have to manually put the base into bootloader mode and flash base with v347. And then motor to v347. This will make the assembly work except nothing on BME works.

I was hoping to test and tune this weekend but now im waiting on support to respond to ticket.

Thought i would throw this out there to see if anyone else has experienced this or if anyone has any suggestions?

Thanks!

Todd

Comments

  • I'd uninstall all drivers/FM and reinstall. Do you have the latest Fanalab beta? That will help too.

    I'm having a similar problem where I have no input from my wheels at all - no LED lights working, not coming up on the control panel at all. I'm waiting instructions from Fanatec, as it may have to go back under warranty, as I can use it at all. The Podium wheel base may have bricked.

  • Hi, I had the same problem with the bmw ring, I returned the DD1 base, and problem solved by buying another one, outside of Fanatec.

  • They responded quickly and sent me instructions in order to update.. It worked for 1 hours , as soon as i ended my session (iracing) the base became dead again. I went through the instructions ( attach steering wheel but disconnect bme. flash v356 to dd, motor, then phub. then plug in bme and re-flash bme) this exact process worked 4 hours ago. Now my dd is dead and unresponsive again. I flashed back to 347 in manual bootloader. re-flashed motor frimware to v347. started this process over 4 times. My dd must be bad if no one else is having these issues. We depend on this sim for driver training. I have emailed back to support and now waiting on them to respond. Support, please advise me ASAP.

  • I think I may have resolved my issue.. But so far so good. I ran a registry cleaner through my pc then cleaned all old dll files. I used cmd to allow all dll to pass in registry and i did this in powershell. (as admin) I then re-installed v356 and updated as above. so far so good. i have used my sim now for two hours in several sessions.. Support, please disregard my last ticket. i will update this tomorrow. It seems there should be a bat or cmd file that clears out and grants permissions. im running win 10 64 1909 all up to date. For now i am happy and i love the way this direct drive feels. as long as i can keep it working seemlessly i will be happy client :)

  • If your current fix doesn't work in the medium term then I would suggest going back to 346 I went to 352 and while it felt like a big step up in feel and fidelity I did not like some of the side effects and there is a lot of negative comments about that and I think for 356 as well. 346 is pretty stable and I am happy to stay on it until a newer version is as bug free as that but with better fidelity.

  • Update: it seems stable now.

    This what i had to do:

    run cc cleaner to clean old dll and registrys.

    open cmd (ADMIN) and executed: regsvr32 /i shell32.dll .

    open powershell (ADMIN) and executed: Set-ExecutionPolicy -ExecutionPolicy Unrestricted -Scope CurrentUser

    re-install v356 and update per instructions above.

    this has worked for me.

  • SPOKE to soon! My dd1 became a brick again and i repeated these steps with no luck... Please fix this!! It looks like there alot of people having problems with this driver.. i have phub and bme. i cant use older versions wiothout it being notchy.

  • i have tried using a laptop with win7 64bit pro. same exact problems. just dont understand and there are plenty of other people with this exact problem.. support, please let us know what is going on?

  • I was trying anything. For now im usung v347 but it so notchy. I tried 344 and 346 they work too but in all those versions they are nitchy. I removed the drivers arms in iracing and its useable. I hope they get this figured out because v356 when it did work was awesome! Now i just cant use my bme.

  • Hi Todd. I am very keen to follow your story as my own DD1 PS4 base is now being sent back to the Fanatec workshop for the second time. My issues are a bit different but in short after updating to v356 I experienced 100 % base fan even after motor firmware update, fast spinning wheel from time to time for a few seconds then full stop and disconnect from base. No force feedback in GT Sport on PS4, did a reinstall of v335 drive wheel then permanently lost connection to the base, no buttons working. Upgraded to v347 did work, all issues still present, upgraded to v356 again, base still couldn't recognize wheel and motor firmware showed as version 0.

  • I have not had any replies from support since tuesday.

  • I was advised that support agrees this is a firmware issue and that i should continue to reply through email. Advised that is the only form of communication they can support after i asked if there could be an easier way to communicate more efficiently. I am trying to be patient and all i ask is that they be transparent and no bs. As you can see when i tried to reply this is what happens. they can no longer receive messages because their inbox is full.


  • It is a bit scary that the only means of communication is not working then even worse that there are so many issues that support can't keep up!

Sign In or Register to comment.