CSW 2.5 FFB feels off after attempt to install Endurance Module on the Universal HUB

Hi guys,

I'm very disappointed and lost. I have spent hours today trying to install the Endurance Module on the Universal Hub with my CSW 2.5. I followed the instructions found online from Fanatec, on the website and YouTube.

Throughout the process, I was very confused as it always seemed to be specifically for PODIUM Hubs, but as the website says otherwise, I just kept going.

After installing the proper drivers etc, I made a first try. First, in game, the FFB went crazy, and went from left to right at full force. I then realised the wheel was in xbox mode. I didn't notice at first, as I never had to change mode before.

After fixing this, i went back in Assetto Corsa to try. Here, the Module kept saying FANATEC PODIUM MODULE and show no telemetry at all ; AND the FFB (to which I am very used by now) felt completely off.

On Facebook, I asked if the Module was compatible with the Universal Hub, and I was replied "not yet"... disappointed, I screwed back everything as it was before, uninstalled the drivers and the Fanalab BETA thing, and reinstalled the drivers exactly as I did when I unboxed the thing.

But.... the FFB is still off ! 😭😭😭 I checked ALL the settings 10 times, and everything's is exactly the way I am used to. Also, the display on the wheel doesn't work on the game anymore. On windows, on the drivers UI, everything seems ok, even the display test works.

I have tried all I could and nothing worked ! I'm disgusted I tried to plug this Module today :(

Do you guys have any idea on what I may have done wrong and how to undo it ?

Huge thanks in advance!

Greetings from France.

Comments

  • The Podium Button Module is NOT compatible with the CSW v2.5 yet - it is ONLY compatible with Podium DD Bases for now. BUT it IS compatible with the hub. So whoever you asked about Hub compatibility who replied its not yet compatible, that wasnt perfectly correct.

    A future firmware update will make it compatible with CSW v2.5, but that update was not released yet and is coming sometime later this year. This information can be found on the product page of the BME.


    Also the driver 356 (which would be requiered for getting the BME ready on Podium DD Bases) is not officially released for CSW users, thats again a DD exclusive driver. Latest driver for CSW is 347. Try that driver, flash that firmware and everything should feel normal again. Normally it shouldnt be possible to damage your base in any way so the FFB could feel any different, may be just placebo or wrong settings.

  • Thanks a lot for your answer.

    I will check the driver installed tomorrow evening and try to flash it back to 347. I have a feeling that indeed i have a higher number installed. Will see and keep you posted !

    Also thanks for the precisions about the compatibility. I wish I had found them before I committed all those mistakes.


  • I did it, and it didnt solve the problem....

    I even tried to uninstall everything, and try back again. No success....

    Even the Gear and speed display on the wheel does not work in game. Only in the Fanatec Property Page test button.

    Here are screenshots. One strange thing is that I have the "Tuning Menu", that I didnt have when the wheel was working well, and that seems to be linked to Podium only !

  • edited February 5

    The tuning menu was added to the driver for all bases, not just Podium.

    the display of the Universal Hub (Not BME) only works in game when you have that feature enabled in the game or when you use 3rd party tools like Fanalab, Fanaleds, SLI Max Manager, SimHub etc.

  • Thanks for your answer.

    It worked before i attempted this installation of the Button module, without any action or even without me realizing something was needed.

    So the fact that it stopped working, aside from the FFB feeling odd, shows that something has been altered, software-wise..... and I can't find what ! :(

  • As said, you may have tried to use FanaLab which disabled native display support so you have to re-enable that in game again.

    ffb should feel the same and is most likely placebo or you previously used different settings. There is no way it could feel any different.

Sign In or Register to comment.