Podium DD1 dead on first day!!

Hi! yesterday i received my new podium base, but its not working. Ive updated correctly both firmware and motor and installed drivers but base doesnt shows any attached wheel (i've tried 2). I need an urgent solution! First day with wheel and its not working?? Sounds like a joke :(

Please find video attached



  • Daft question as I can't see the video. Is it in PC mode?

  • Hi, yes, PC Mode (OLED screen shows PC). My problem is that motor FW is set yo 0 and i cant update It. I've seen several guys with same issue here, and RMA seems to be the only solution. I have tryed all firmwares (beta and final).

    This is unaceptable for a high end product.


  • Try updating motor firmware with no wheel attached.

  • I also try that, no wheel and no torque key, but same result :(


  • Joseph GossenJoseph Gossen Member, Moderator

    Cannot open the link. What driver/firmware version are you on?

  • I have try all of them with same result :(.

    RMA is opened, but this situation doesnt say good things about Fanatec QA processes.... Brand new product broken on first hour and now i have to wait weeks for a replacement?? Ridiculous.


  • You have a right to a refund if that is the case. I have the same problem with my DD1 and haven' t now had a wheelbase for 3 weeks. I'm waiting for Fair Trading Australia to demand a refund or major improvements to the software/firmware, otherwise we are at a point, in my opinion of a product not fit for purpose as it is still in development stage.

    I've said this before, don't use the Beta firmware as it's unstable and could be the root cause. Same with Fanalab. I uninstalled it completely.

  • Yes, this is completely unaceptable for a premium device. Fanatec MUST chance their policies in orden to protect the customers interesest, and return money or send the replacement product in the moment you drop the broken one into courier.


  • Hi Gabriel,

    I too recently received my podium DD1 PS4 - and updated it, it then stopped being recognized - I downgraded the firmware (keep power button pressed for 8 seconds) and then motor firmware to the last non-beta firmware (and calibrated them), then the day after I tried upgrading again - and this time it worked (uninstall non-beta drivers, install latest beta, upgrade firmware, re-center the wheel, upgraded my wheel version (might not be needed for your wheel), upgraded the motor firmware, removed wheel and re-calibrated motor) - I was freaking out after the first attempt failed with the beta, thinking the DD1 might be bricked.

Sign In or Register to comment.