Podium DD1 won't power down HELP!

Hi all,

I just received my Podium DD1 ps4 wheel and porsche button endurance with v3 pedals. I was able to go in and set up my drivers and fanalab software, but the software froze and now my dd1 won't power down. The led window just has the Fanatec name with "Podium Wheel Base DD1 PS4" showing at the bottom. I have had this for less than 4 days and finally was able to use it once my mount arrived. I have tried to find a way to contact fanatec through the website and can't find a way to do it anywhere. Has anyone run into this problem with their DD1?


  • What was the fix?

  • Had to unplug the wheel base to power down, then uninstalled the drivers, rebooted the system and powered up the wheel base, then I was able to regain function and reinstall the software. When I first unplugged the base and powered it back on without uninstalling the drivers and rebooting, it didn't function and had the same issue with being unable to power down. This worked for me, hope this helps someone if they run into this as I did.

  • Great, thanks for posting the fix here!

  • I take it you updated the firmware on the wheelbase on driver reinstall or am I adding unnecessary complexity to your methodology?

Sign In or Register to comment.