Podium DD2 can not update firmware BRAND NEW

Im trying to send a support ticket thru fanatec website,and even that doesnt work,every time after I click on submit the form,it just wipes all the comments ive wrote in it,so it kind of leaves me no choices other then posting it here.

Wheel Base Model: DD2

Steering Wheel Model: Podium Hub

Driver Version: v374

Base FW Version: v651

Motor FW Version: v40

dear support:


I have not had a chance to use the dd2 until today,and I have ran into some issues:

After turning on the wheel base,it asks for an firmware update,as the wheelbase goes into bootloader mode(flashing white led),I try to click on connect button,but it only shows up with an error message:Please connect the wheel correctly and set it into booloader mode.

It seems like the issue is only there once wheelbase is switched to bootloader mode after powered on.

I have tried every single driver,including all versions of beta driver from the official forum with no success,other then the motor driver can be updated only,with motor fan constantly on 100% duty even after motor sensor calibreation was carried out.

I have also tried the following with no success:

-changed to different usb port of the pc (2.0 & 3.0)

-tried using an powered hub

-took off p hub and installed driver

-disconnected pedals,shifter & handbrake

-disconnected all usb connected devices to PC

-device manager delete device & rescan device

-swap to different ports of usb input in pc while in bootloader mode

-USB selective suspend setting is disabled

-manually switch input into bootloader mode

Running on Windows 10 pro.64bit system.

Hopfully someone from fanatec could get in touch with me asap,this is literally the first time I have turned the wheel on !


  • Could be because your motor firmware is too new to communicate properly with the Wheel base.

    Try downgrading your motor firmware by installing driver 346 and flash the motor firmware with the included one back to v30 or what it is. Then try to flash the base firmware.

    If that worked you are back at a working combo and for future updates always update the base firmware first before updating the motor.

  • Hey Maurice. I’ve done all of the procedures from out of the box install. Which originally the motor driver was a V30 with the official driver from fanatec site,and it was just giving me that error message once I click on the connect button for wheelbase firmware update. I’ve tried every single driver I could possibly get my hands on From here and official site. Regardless of whichever version driver it runs,it only allow me to update the motor driver itself, As soon as I try to update the wheelbase firmware,it just gets stuck in a bootloader phrase & will generate that error message regardless of whichever version driver or motor firmware which I have tried each motor firmware based on different version of drivers.

    Ps:please disregard the different account I used for purchasing of the wheel. Thanks.

  • looks like your actual wheel isn’t connected properly. Have you tried removing and re attaching your wheel?

Sign In or Register to comment.