Problem switching modes from PC to Xbox

Recently bought the ClubSport Wheel Base V2.5, ive updated through all the firmware on the Fanatec website.

Now im having a issue with switching my wheelbase from PC mode to Xbox Mode. the "START" ring will not switch from red to green as it indicted when i press the "select+Y"

I've tried multiple times and running out of options.



  • The Clubsport Universal Hub

  • According to the manual you need to press select + x if you have switched back to another mode than XBOX mode. I assume you have connected it to the xbox and it still stays in PC mode? Please try select + x

  • Thank you, I've tried that multiple times and nothing seems to work. It always stays in the "red ring" mode.

  • "s_1"keep on showing up in the middle of the hub, not sure if that has to do with anything?

  • edited September 2020

    S1 is your saved tuning profile N.1.

    Maybe you are not pushing simultaneously or using the wrong combo of button and it is registering only the tuning button menu hence it is throwing you to the wheel settings menu.

  • Psql .Psql . Member
    edited September 2020

    I think you need to be out of the tuning menu to be able to change modes. So click first tuning menu button so there is no s_1 or similar with other number on the display.

    If the display is empty try to click the 2 buttons. You don’t have 2 click them simultaneously just first keep the button with squares pressed while pressing that one, press Y button. This should change the mode.

  • Then you are in the tuning menu. Then switching modes is not possible

  • Still having problems. Ive updated the wheelbase to PC Driver: 373 Wheelbase Firmware: 674 Wheelbase Motor Firmware: 22

    ive unplugged both Wheelbase (CSV2.5) and Pedals (CSV3) from computer and connected to my Xbox One X. tried pressing the buttons to switch modes, nothing happend. Still red ring on "start" button.

    I noticed there is a USB port on the bottom side of my Universal Hub, do i need to connect a USB to USB on the bottom side of the Universal Hub to my Xbox as well for the mode to switch?????

  • For anyone having this issue, use the X button and Menu/Select button at the top of the wheel next to the screen to switch to Xbox Mode. The buttons on the face of the wheel do not work for switching to Xbox Mode. Not sure why... 🤷‍♂️

  • I just bought a second-hand CSL P1 wheel for use with my CSV2.5 base. It worked perfectly the first time it was attached, but now I can't get it to switch back into Xbox mode. Did anyone find a reliable fix for this problem?

  • I've recently begun to experience this issue. I purchased the Formula V2.5X wheel earlier this year and everything has been working flawlessly. Now, I've added the Universal Hub V2 for Xbox, which is also working flawlessly. But, when I try to switch back to the Formula wheel, it will not allow me to enter Xbox mode. I can swap back to the Universal Hub and it works fine, but not the Formula wheel.

    I seem to be able to work around the issue by completely powering down and unplugging the CSL DD. But if I swap wheels the problem returns.

    I also added the CSL load cell brake, but that doesn't seem like it would be related. All firmware is up to date.

    Has anyone found a solution?

  • So I noticed the same problem. Now that I have a universal V2 hub my Formula Wheel doesn't want to change into XBOX mode. What I have been doing as of late is I will put my V2 hub in then switch to the formula wheel. But I mean this is a bug in the system that needs to be fixed. The hoops I have to go through just to get my formula wheel to work is crazy.

    Can you detail your solution a little bit better maybe we can at least help each other out with a work around until Fanatec puts out another firmware update. I have tried complete reboot of the XBOX and the DD Pro. I will power up the XBOX 1st then the wheel and again won't go into XBOX mode. Even when I use control panel just won't activate the security chip in the wheel

  • My workaround has been to disconnect the CSL DD from my Xbox and power. I typically will wait several minutes until the power supply no longer has the light lit. I make sure my Formula wheel is connected and then power the CSL DD. The last thing I do is connect back to the Xbox. I may get a quick USB error message in the OLED display on the wheel. This is typically a sign that it will switch to Xbox mode.

    It's nice to know I'm not the only one. Do you typically "hot swap" wheel rims?

Sign In or Register to comment.