Help: USB connections failing when I start DD1 wheel base

Hi All

Hoping someone may know how to fix this issue;

when I start the PC and open the Game controls / fanatec wheel Property Page I can see my peripherals and in the properties tabs on each one I can see they work fine - until I press the power button on the DD1 Wheel Base: Then windows will chime and I have lost display on the SLI and lost USB Gear shift. when I go to control panel everything is in order ( no yellow warnings) I was running the recomended 352 beta driver and also did the same so I updated to current... thinking this must be a windows thing but hoping one of you smart cats might have worked this out already cheers for the help...

Running latest beta drivers

PC driver 373

Wheel base firmware 674

Wheel base motor 40

Steering wheel Firmware 3


Periferals I'm running:

SLI Pro

JINX Shifter - (bodnar board)

DSD Buton Box

Comments

  • Try disconnecting the additional peripherals first and see if you can just get the base and wheel to work. Try turning the device on before starting your machine too. You could also try going into device manager, find the Fanatec USB input device and remove it then try again, or try again on a different USB port.

  • Start windows without aditional programs (run msconfig check the box hide windows programs disable the rest) see if it works ok. If it does start programs one by one ntill you get the error. I know togh process but 90% of the time is your pc fault;)

  • Thanks Guys,

    I have tried all those things ( deleting Firmware , rolling back fanatec drivers, changing ports, runing msconfig, scannow, even memory diagnostics.. I think its a 3 way clash between the recent update with windows 10, Fanatec driver and the SLI Max Manger software affecting the USB ports...

    At this stage I can run ALL but one peripheral " if I leave the SLI unplugged all button boxes, Gear shift and DD1 works perfectly, if I leave the wheel turned off then I have SLI and all peripherals working also... Just cant run both the DD1 and SLI at same time..

    All these perpherals were working fine until windows updated about 3 weeks ago so I'll try to stay calm till the next update... what gets me is the devices drop out ( windows does its chime to say somethings unpluged but no errors in the device manger either ??

    Anyway appreciate your help

Sign In or Register to comment.