NEW WRC XBOX WHEEL NOT WORKING WITH CSL ELITE PS4

Hi,just bought the new WRC wheel for the csl elite PS4 from fanatec so I could also race on Xbox one.attached the wheel and locked it in place with the new quick release and powered the base up.on start up the wheel does its standard wheel right and wheel left then centre and the revleds light up ALL EXCEPT THE 3 BLUES.no display from the indicator that shows speed and the Xbox is not registering that the wheel is connected in settings.no buttons work.....nothing.tried re-attaching 3 times and nothing.attached my p1 PS4 wheel and that all works fine with PS4.i have tried pressing the mode button as the green led did not light up for Xbox mode and it only flashed green and red once I held the mode button for 4 or 5 seconds.really stumped as to whether I’m doing something wrong.the wheelbase is 2 months old and the firmware was checked in July and was up to date.

can anyone help or have any suggestions.i have tried fanatec support but have had no response as yet and don’t have any faith that they will respond soon based on other customer service comments I’ve read on internet.

any suggestions would be grateful.

thanks.

Comments

  • edited September 10

    You already updated to driver v374? And updated firmware of your base to the included version of the driver v374?

  • Pasqual

    I asked a friend at work to see if the wheel needed an update but I haven’t updated the base unit.forgive my lack of knowledge on this topic but do I need to check the firmware on the base even though it was up to date in July?

  • Yes because a new version was released when the wheel got available a few weeks ago. So your July version will be outdated to support the new WRC wheel.

    So update to the firmware included in the v374 driver which you can find on the download page of the WRC Wheel.

  • edited September 11

    ** All sorted !! , open Fanatec Wheel Property Page , select CSL Elite and do a firmware update through that and it will fix it all up , you will need to calibrate the wheel again. hope this helps



    I just received my wrc rim today also and am having same issue , have tried v374 driver and still nothing. no lights on wheel , and slow blinking on wheelbase , any help would be greatly appreciated

  • Hi Murat, did you update the wheel base firmware using the 374 driver?

  • Hi, I just got the WRC wheel for my CSL Elite PS4 base but when trying to update the wheel base firmware it fails every time. In the updater instructions box it says "click connect button" and in the message logs box it says " CSL Elite PS4 Wheel Base Detected" if i click Flash Firmware the green bar fills then in message logs it says "No Response from the device. Operation failed" Has anyone else had this problem? I sent a support request over 2 days ago but still waiting. Previous to this i had no problems using it with F1 wheel on PS4 and PC (windows 10, 64 bit).

    Any help would be appreciated.

    Thanks

  • I got a different proflem. I ordered the wrc wheel and a handbrake. i've installed the firmware, callibrated. Everything works fine on the property page. Works as intented on assetto corsa, on gran turismo sport i only have sequential and handbrake, on DiRT i only have sequential no handbrake. I can't seem to get the H shifter to work on gran turismo and dirt, i callibrated multiple times but they worked fine in the past. Could this be firmware issue?

    Any help is welcome. Thank you.

  • Ich habe das WRC auch heute bekommen, alle Treiber und Updates installiert, und es funktioniert der F1 Rim, und der Mclaren Rim auch, nur beim WRC Rim ist der Wurm drin. Hin und wieder wird es als P1 Rim PS4 erkannt und es funktioniert keine Taste. Oder es leuchtet nur der Streifen oben. Und sonst nix keine Anzeige auf der Testseite


  • Hi Torsten,

    Please right in English as per forum regulations so more users can understand and maybe try to to help you.

    When you say that you have done all the updates have updated to driver 374 with all the related firmwares as per the instructions in Fanatec website on the download section for the WRC wheel?

  • Yes i've installed the driver 374 on my Pc,and flash the firmware on the dd1 + my 2 other rim,but the wrc rim isn't appear at the property software, or sometimes as the ps4 p1 Rim but no button works. It shows no Rim Update on the Property Page for WRC ether. When i start the Base with this Rim the Wheel Icon on the Base its also missing.


  • Better contact support through your account in Fanatec site. 


    Did you also flash the wheel (like you did for your other 2) and still shows as P1? 

  • I've contact them 1st. They haven't answer till yet.

  • edited September 17

    I have updated my CSL E to the 374 in prep for my WRC wheel arriving tomorrow. One thing I haven't seen mentioned is the new bRi, or bR1 setting in the wheel tuning menu. It is defaulted to off, but seems to have 1% increments. I haven't been able to find mention of it anywhere.

  • Most probably you mean the BLI setting formerly known as ABS. Got renamed because the name was confusing and it had nothing to do with Telemetry based ABS.

Sign In or Register to comment.