Tried to update pedals but now stucked on updater

I press for error "firmware update" and now I'm on tue pedals firmware update tab... stucked on it... I've not fresh new driver or hex files to upload and i can't kill this process! Also if I kill that when aI connect pedals it starts up again... How can i Stop this process?


  • Why did you tried to update the firmware in the first place?

    There is and there never was any newer firmware available since the CSP v3 were released so there is no need to try to update the CSP at all.In general, you should only update if the driver tells you that your installed firmware is not the most recent one.

    Anyway, in the picture the flashing process did not started so you should be able to just pull the usb cable, restart the pc and connect it again, then the update should not open anymore. If it still does you may have already bricked the pedals somehow... you could try to reflash the firmware then. If that also doesn’t help then you should donate the technical support.

  • Hi,

    exactly the same problem for me, i did the mistake to try to upload latest firmware like said in "ClubSport Pedals V3 Manual".

    Now the firmware is erased and impossible to find firmware file .hex in "drivers package" or on fanatec website.

  • Still happening five months later (or five years if you count all the reports from 2016)

    Has there ever been a fix?

Sign In or Register to comment.