Club Sport V3 not Recognized

Is anyone having issues with their pedals not working? When I first received the pedals, they worked flawlessly and I was very pleased. Then all of a sudden, they would cut out in the middle of a race. Initially, the error seemed to be sporadic, with really know known reason.

I have tried to contact Fanatec since the middle of August, with the responses being 5-7 days after my email, and at the end of last week they finally sent me a new PCBA board to install. After I installed the board today, I am having the same issues.

What am I missing? I have used different USB cables, thinking the cable might be the issue, AND I have tried using several RJ12 cables with no remedy. (And before you ask, YES, I connected the cables ONE at a TIME---didn't have them both connected at the same time.)

I am at a complete loss, as I have invested a lot of money, time, energy and effort with little to no support.

I welcome anyone's suggestions on how to proceed.

Thanks in advance!

Comments

  • edited September 14

    Wow. That is tough. Those V3 pedals have quite a good reputation for durability and dependability. See if you can continue communicating with customer support and hopefully via process of elimination they may be able to solve the problem. I know they waiting time is tedious but may be worth a shot. If nothing solves the issue you may have to send it in to them to check out in more detail or consider other options.

    BTW, how old is the V3 pedals and/or how long have you had it?

    .....Also which games are you using it for and on which platform....PS4, PC, Xbox or what?

  • I had a load cell issue on my brake pedal. Ended up calling Germany for support. Way faster than email. What wheel base are you using?

  • I have the CSL Elite bundle with the CSL Elite wheelbase. I got the wheel, wheelbase, pedals, and a shifter no more than 2 months ago. The only game i play is iracing on PC, and when my pedals used to work, they were amazing. Then they started disconnecting randomly in race causing other people to run into me and resulting in them getting mad for something i couldnt control.

  • You seem to have done a lot of troubleshooting already from what you mentioned. It's a hassle right now but I have no doubt since you only have the stuff only 2 months now (I'm assuming you bought it new from Fanatec right?) if y'all can't solve the issue they'll give you a replacement via RMA.

    Some time ago I used to have intermittent disconnection issues myself and for the life of me I couldn't figure out what it was and we tried various things. My situation though was playing on PS4 console and not PC like you. In the end it turned out to be the console was giving issues. When I ran out of options I thought to myself let me buy a new console and see if it helps. Low and behold when I did that the problem was solved. I think either the previous console was either dying or something was mucking up inside.

    That being said I'm wondering if the problem may be emanating from an issue with your PC. Just a thought.

Sign In or Register to comment.