Clubsport 2.5 - no FFB in WRC9

Ive just installed WRC 9 and the game doesnt recognize my wheel until i restart the wheel base when im in the game, and after doing so the input works but theres no FFB at all.

Ive tried to reinstall the game and wheel base drivers but it doesnt change anything.

Anyone has a solution? :/


  • I also have this problem. I cannot figure out a solution to this. I can get the wheel to input into the game, but there is no feedback. The feedback is all grayed out for me in the settings.

  • Yeah, same for me but i can get the FFB settings to show but still no FFB. I've tried driver 3.74 and 3.73.. no difference but i swear the FFB felt completely different when i went back on DiRT Rally 2.0... Like WRC 9 would alter the Fanatec driver. Also, im using the V3 pedals and the function "test ffb" for brake and throttle doesnt work after WRC 9 installation.

  • Check you don't have any background programs conflicting with the FFB in WRC 9 , when i first started with WRC 8 i had no FFB at all and it turned out to be a little program called irffb (used for iracing) , once i uninstalled/disabled this my FFB in WRC 8 was back.

  • Didnt find a program called irffb sadly :/ Still doesnt work and im thinking if a clean installation for windows 10 might help or not :/

  • Anyone ever solve this? I have the same issue. I have uninstalled and reinstalled the game 3 times, uninstalled and reinstalled the wheel driver/Fanalab once. I have searched/read around the web, tried lots of button mapping, tweaking settings, etc. I had force feedback for two stages early in this process, but nothing lately. Been struggling with this for 3 days and CANNOT get any FFB in WRC 9. CSW v2.5, V3 pedals, shifter, TM TSS handbrake. Everything WORKS in game, but no force feedback at all, completely FREE wheel. Go back to Dirt Rally 2.0, everything works fine.

    I don't have any programs running in the background that would affect FFB I don't think, and a reinstall of Windows is off the table unless someone reports that this actually might work and why. The game looks like fun, but a Windows reinstall CANNOT be the solution, can it?

  • I solved it! It was my Xbox Controller causing it.. WRC9 thought my wheel was the controller.. wheel input worked but the FFB signal went to the controller...

    I simply uninstalled the controller drivers completely and be sure not to use any other device in the same USB port as you have the wheel.

  • Huh, well, I don't have an Xbox controller, so that ain't it!! I did a reinstall of Windows 10, it was time anyway. I'll see how it goes now with a fresh start.

    In WRC 9 controller setup, there WAS a Logitech G920, which I used to own but no longer have installed. Don't know where WRC 9 got that from, but maybe with a clean install of Windows it'll work. 'Course, can't check until I get everything back setup, which takes a while!!

  • Then the G29 might be the issue. A reinstall of windows will do the trick most likely or delete/uninstall all drivers related to G29 (if u ever had one before)

  • OK, the Windows reinstall fixed it, but even then it wasn't simple!! I think I learned that if you change anything in WRC 9 control settings you have to quit the game and come back in. I change one setting, force feedback doesn't work. I uninstalled and reinstalled WRC 9 about 3 more times before I figured that out. So now to start tweaking video and control settings to get it "right." Hope I don't screw it up again.

    Developers should warn people that having "old" USB control devices showing up in the game controller settings will likely screw up FFB. And you can't delete them even though I've read that you could create a custom profile for one, delete that, then delete the original, but that never worked for me. I could NOT delete the old Logitech G29 in the game. I've also read around that mapping everything to your wheel would fix it, but I don't know for sure how to do that exactly.

Sign In or Register to comment.