Help Needed With Steering Controls

Help Needed with Steering         

I’m starting to think that I may be an idiot, but my new Fanatec equipment isn’t performing as I suspect it should. For example, when I start out for a practice lap in Cars 2, the car proceeds slowly down the pit lane and moving the steering wheel has NO effect (I suspect it should). Once the car exits the pit lane, it veers to the right and I crash out. No amount of turning the wheel does much of anything.

Part of the problem is that there seems to be all sorts of different directions and few of them incorporate my exact set-up which is as follows:

·        Podium wheel-base DD!

·        Podium wheel rim Porsche 911 GT3 (not buttons)

·        ClubSport Steering Wheel Universal Hub for X-Box One

I originally intended to run this on an Oculus Quest with the Line Cord, but it got so complicated that I’m now starting by trying to run it on an Alienware Gaming Computer.

I’ve tried to configure this several ways.

The first is to try to follow the instructions in the manual for the ClubSport Wheel Base 2.5 on-line. These are about completely indecephirable:

After beginning the instructions in 7.1.3 Switching modes, it says “In case the ClubSport Wheel Base V2.5 is in PC mode with attached Fanatec Streering (sic) for Xbox One you have to connect the wheel base to the Xbox Oneconsole via USB cable and the press the buttons two screens + Y at the same time.

Question 1: What and how do you connect by a USB cable? There is a USB slot in the CS Universal Hub, but no place to connect it to. Should anything go into that slot? If so, do I need a serial port to serial port connector? Not a clue!


Next it says that the double screen + Y allows to toggle between PC and Xbox One mode when a Fanatec Steering Wheel for Xbox One is attached, with other Fanatec Steering Wheel the ClubSport Wheel Base v2.5 works on PC only. PC Mode is indicated (sic) by ret lit ring of light.

Question 2: Where am I supposed to find the red ring of light. The only light on the universal hub is a very small one, nothing printed on it, and in my experience, it only glows clear.


Next, we go to 7.1.2 Wheel center calibration. The first step is to enter the tuning menu. That is fairly straightforward. Later, it says,  “When you use the ClubSport Universal Hub (which I think is the case), you must press the start + x on top side of the Universal Hub at the same time to calibrate the wheel center:

Question 3: There doesn’t appear to be a “start” button on top of the hub, so what should I use in its place? 


However, in the next sentence it says, “When you use a Fanatec Steering Wheel for Obox One, you have to press the Menu + A at the same time to calibrate the wheel center (e.g. Universal Hub for Xbox One, ClSL Steering Wheel for Xbox One.). Is anyone starting to get the idea that this is getting very confusing?

Question 4: It appears that the Universal Hub can provide some data. I don’t have a clue how to turn that on? Is there a secret?


This is just for calibrating the center. There are some other calibration tests in assorted software.

One of those firsts asks to turn the wheel all the way to one side. It takes two or three complete turns to reach that point. Does that mean that represents the complete turning radius of the wheel? Am I supposed to leave it there or do I re-center it? No one provides any guidance. Then the next instruction says to turn the wheel ninety degrees in one direction. Where is that supposed to be from. Where the wheel was rotated in its entirety or from the centering position?

Then there is another set of instructions that first says to turn the wheel in either direction. Following that, I’m then asked to center the wheel. What is that supposed to do?

All that I want when all is said and done is a car I can steer. Right now, the car seems to have a mind of its own and I have no idea how to get out of that!

I hope someone will take the time to read this and respond. Fanatec will likely tell me to read the instruction guides, but they are basically too long and as shown above, inconsistent.



  • John KothanekJohn Kothanek Member
    edited November 2020

    I don't have the answer for you but in my experience in project cars the trip out of the put lane is controlled by the game and before I realized that i'd turn the steering wheel and I think that input ends up messing with it when the steering is first turned on. Have you tried going down pit lane and not turning the steering wheel and it still goes nuts as soon as you have control?

    "Then there is another set of instructions that first says to turn the wheel in either direction. Following that, I’m then asked to center the wheel. What is that supposed to do?"

    I think that calibrates the wheel and with the console or pc it helps the system communicate the left and right limits of the wheel. I've used that more than a few times and it helps. I have also experimented by not turning to the max L/R (maybe 80%) and it seems to help give me more "sensitive" steering inputs.

Sign In or Register to comment.