CSL Elite base and steering not connecting correctly

Hi I have a CSL Elite Base and steering PS4 compatible and it is under a week old and today when it was turned on it didn't start up correctly and the display on the steering wheel at the top wasn't illuminated and it doesn't centre the steering wheel and the shift lights don't light up during its initial start up and then the red light flashes. We tried to reset it and reload the firmware and then we tried to calibrate it and this is when we found that the buttons weren't working either. Looking into this model now it seems we should have just gone with the Clubsport and not worried about the PS4 compatible stuff as we bought the V3 pedals. If Fanatec view this I would love to upgrade the steering as it sound like the CSL Elite is a problem child.


  • Also sorry I should say I sent the Tech support team a message and I'm waiting to hear back from them

  • I have sent a request to support and haven't heard from them yet. Figures crossed we hear from them shortly as the unit is only 5 days old

Sign In or Register to comment.