CSL Elite V1.1 not recognized anymore

Hi guys,


My fanatec gear(CSL v1.1, P1 & CS Pedals) is not recognized anymore on both PC and XBOX.

To be clear, by not recognized, I mean that the PC and XBOX don't even see that I have connected any fanatec gear.

No notification when I plug the usb...


I haven't played on them for like 4 months. Last time they worked perfectly, but 2 days ago I wanted to make a quick firmware update. I plug it into my PC and it didn't get detected, I plugged in into my XBOX, same.

The wheel starts and initializes correctly, I checked that I'm in the right mode for PC and XBOX. I can enter the wheel's tuning menu and change any setting I want.

I checked the actual USB cable, nothing wrong with it, I reinstalled drivers, I even tried it on a different laptop and still it does not get recognized... Nothing appears in the devices menu from control panel inside windows...

I checked the usb connector on the wheel base and I can't see any damage.

I then tried to plug it in the my xbox, and again same issue, it's not recognized. The wheelbase initializes properly, it spins the wheel, it tuns on the lights, then two numbers appear on the lcd screen: 664, 022 and then 3 lines: _ _ _

However, the led below the xbox button remains switched off. I can enter in the wheel tunning menu and and adjust the wheel options just fine. The same 2 numbers and 3 lines appear if i plug it in the PC.

I also tried the bootloader mode, and still it didn't got recognized. I had the wheel & pedals attached to the wheelbase when I did this. Should I only have the wheelbase plugged in when I try this?

What's even crazier is that if I put the usb in the PC, after the initialization, the led turns red automatically and if i plug it inside the xbox it turns greeen automatically, as if it knows in which device it gets plugged in, but none of these devices recognize it...

I also tried a fresh driver install on a laptop, and still it didn't recognized the wheel, wheelbase or pedals.


I don't know what happened, it worked fine on both PC and XBOX, I didn't play for like 4 months, and now after I plug them in they don't work anymore, the only possible issue would be the updates? Both windows & xbox have the latest updates from microsoft. The PC does not have the 2004 update however since it's still in not mandatory.


Does anybody had a similar issue?

Sign In or Register to comment.