Wheelbase (CSL Elite PS4) freeze when I connect the new wheel formula V2 to the base in Xbox mode

My wheelbase freeze when I connect the new wheel formula V2 to the base in Xbox mode. It works normal in Pc and PS4 mode.

 

I can not even cycle between modes, because everytime in switch to xbox mode it freeze. Only if I disconnect it from the power source the base start again.

 

I have no problem with Universal Hub for Xbox mode. It works in all three systems normally. ( PC, PS4, Xbox One).

 

I am using drivers 346 and have updated everything.... The new Formula V2 wheel too.

Tried with 347 drivers but it is still the same.

 I wrote to support but I think that they will reply to me after the weekend.

https://streamable.com/aau8oe


Looking forward to hearing from you.

 

Comments

  • È successo anche a me ho mandato volante e motore in assistenza perché nemmeno loro sapevano darmi una spiegazione... quando è tornato tutto funzionava

  • Ok. Anche io sono in contatto con il supporto tecnico. Sembra che anche io dovro mandare tutto in assistenza.


    Grazie Roberto.


  • I am having the SAME EXACT ISSUE! I literally just purchase the CSL (PS4 version) with the intention of having cross console compatibility as their website advertised. Since I currently have an Xbox One Slim (White), I purchased an Xbox compatible wheel (Formula V2). I also purchased CSL Elite pedals.

    For the life of me, I spent countless hours trying to just enter Xbox One mode (green light). I was only able to do enter xbox mode 4 of the 50 times I tried to. The simple "hold the double-square button and Y" doesn't allow me to cycle to xbox one on demand. After my first successful mode change to xbox mode, my system froze. I couldn't even use my normal xbox one controller. The wheel base locked up all controls and it required me to pull the power cable as well. my last successful attempt allowed me to successfully enter Xbox Mode and it worked; however, then my pedals stopped working!!!!!!!! SMH. AFTER THAT, I assumed that it was some type of firmware glitch. so I opened up my fanatic properties on PC and guess what.. no longer had a pedal response from brake nor throttle. The only time I got any input registered on the properties via PC is after I moved the RJ12 cables around under the pedal base (FYI, pedals were ALWAYS connected to wheel base via RJ12 cable provided by Fanatec).

    Since then, I was never able to successfully get back to Xbox Mode to further troubleshoot the compatibility and pedal issues. Firmware installations were executed for base, motor, AND wheel multiple times with no fix! I Literally had my equipment delivered last night! I don't understand how a company with such good products drops the ball like this? I am sincerely hoping we get some positive resolution before we opt for a return (or possibly even dispute for a chargeback for misleading/defective products-if reasonable resolution can't be rendered by Fanatec).

    Come on Fanatec, I know you guys have something to help us out. :)


  • I have send my new Fanatec Formula V2 and the CSL Elite Ps4 base to RMA.

    They will check the base and the rim to see what is wrong. The strange case is that the base works perfect with the Xbox Universal rim. With the formula V2 I was able to enter in xbox mode only by turn the rim some degrees to the right as soon as the calibration end, just after the green light turns on.

  • ahhh man!! you know what's funny! I found out the issue through THRUSTMASTER! So apparently, there's an issue with fanatec wheels with Xbox One USB ports as they are known to be glitchy with racing wheels in general (just assuming-considering that Thrustmaster tech support put out a PDF on it).

    Thrustmaster Link: http://ts.thrustmaster.com/faqs/eng/thr_eng_00148.pdf


    So I pulled the power cord on my Xbox One S to hard reset the USB ports. After reboot, My wheel worked flawless until I had to reboot it again!! SMH!

    My Steps as follows:

    1.After you jump into xbox mode (green light) and it freezes-pull the power on the wheel base.

    2.power down the xbox and pull the power cable out for about 30sec.,

    3.plug the power back into the Xbox don't boot it

    4. plug the power back into the wheel base and turn it on (at this point, wheel base should jump right into xbox mode automatically).

    5. Power on the Xbox via xbox home (xbox should turn right on)

    6. all behavior functions worked as normal. I played F1 2019. and the wheel was recognized as "Fanatec universal hub" but everything was good; however, I played project cars 2, the wheel worked fine but the correct type of wheel wasn't recognized neither??

    after that, I was back to square one with this new process (frozen with xbox green light). smh also found out that my CSL Elite pedals weren't working due to faulty/loose RJ12 input on the pedal box:


    Following this breakthrough of false hope, I get blindsided with this BS email from fanatec Stating that the CSL Elite PS4 wheel base is not compatible with Xbox one AT ALL?? but their website says otherwise??? on top of that, the YouTube video link contradicting themselves COMPLETELY and the video was released just 4 months before the Formula V2 was released. AMAZED!!!!!!!!!!


  • edited April 28

    Maybe that USb ports are your problem, but my problem has something to do with the wheel or rim. Because my wheel freeze even if not connected to Xbox One with formula V2. With Universal Hub it works perfect even on Xbox. Today Fanatec informed me that they received my wheel base and formula V2 rim. They will check the problem and send it back to me.


    And most of all I must thanks the support team. There are very professional and kindly in helping me true the problem.

  • Well im sincerely glad you're one step closer to a resolution. I don't mind sending my equipment back, but they blatantly told me that my wheel base is NOT compatible? which sucks and it's definitely confusing.... let me know how it goes for you. I'll keep you posted as well.

  • Hi Guys I’m having this problem now and I just don’t know what to do I’ve tried loads of drivers and updates I’ve had it working once on Xbox but now every time I switch wheels it freezes. Did any of you get it sorted?

  • Hello guys, I've been following this to hopefully get a solution to this. In the meantime I figured it out how it works for me. (Setup: csl elite + ps4 / csl elite pedals / csw formula v2)

    - So you want to power your Xbox One completely down, and pull the power cord.

    - Make sure your usb cable of your base isn't connected to something, start it up and select the xbox mode. (sometimes it requires to shut it down and start it again to "find" the xbox mode when you cicle through them.)

    - Put the power cord back into your Xbox.

    - Connect the USB cord of your base to the xbox (I'm using port 1 on the backside, shouldn't matter really but just in case)

    - Now power the xbox up by using the xbox home button on your wheel. Maybe you have to press it twice to start up.

    Now it should be working. I noticed a bug where the wheel goes full lock while the game loads up, to release it from full lock just press the xbox home button while the game is loading.

    I hope it works for you guys too.

  • So, this seems to work. But you would have to do this every time you reboot your Xbox! Once you turn off your Xbox, the wheel becomes unresponsive again. Only way to get it to work again, is to repeat the process all over again.

    This is extremely annoying. Ain't no way products at this price point should be having me going through all this hassle, meaning I could never quickly jump in a game in 1 minute. It would always have to take me a couple of minutes to go through the whole cycle. And if I do one thing before the other in the cycle, it doesn't work, meaning I would have to start all over again. Both my previous (much) cheaper Thrustmaster wheels worked by simply plug-and-play. Is it too much to ask for a product at this price point to be able to do the same?

    I really hope Fanatec comes with at least a statement in which they acknowledge the problem and that they are working on a solution. Now we are just left on our own on a forum, experimenting, trying to help each other out, while the ones helping us should be Fanatec. This company generally makes pretty nice products, but their costumers service is trash!

Sign In or Register to comment.