Really Pretty Paperweight

When this wheel works it's pretty awesome. However, it has worked for exactly 3 days since I purchased it on September 4th. First it would just lose connection and continue in whatever direction the wheel was in when it lost connection. Not so great in iRacing. Contacted support, they had me do the normal software/firmware upgrade to the 373 package. Tried another usb port and all that. Ran fine for 1 day. Following day get everything connected hoping to race, wheel is recognized however none of the control inputs are working. Go into the fanatec wheel control software "an error occurred connecting to your device, try restarting your device. If the problem persists contact support."

Restarting the device did nothing. I contacted support and have heard nothing for 4 days. Any help is appreciated. I'm outside of the window for 'send this pos back for a refund' so I need someone to contact me so we can talk about this. I'm really frustrated after spending over $600 for something to not work and have support not getting back to me. I followed your process for opening tickets, serve your customers better.


CSL Elite bundle for PS4


  • Dominic BrennanDominic Brennan Member, Administrator

    Hi Rick,

    According to our system you were sent a message earlier today. If you don't see it in your inbox, please check your spam folder.

    [Fanatec Community Manager]

  • The amount of issues I've seen mentioned by users with a vast majority being while using in iRacing I'm beginning to wonder if a great majority of the issues are related to the iRacing game/software and platform.

  • Not just iRacing, had the issues in F1 2019 and 2020 also. I just spend more time in iRacing than the others.

  • Update: yes, someone sent me an email that same day. They basically asked me to try a new usb cable and different pc. Neither of these things fixed the problem. i replied within 10 minutes of receiving that email. Have heard nothing back since then. This product worked and now does not work, that doesn't seem like an issue with a usb cable or my pc.

    Powering off and powering on does not fix the issue. I have contacted support for further assistance and have not received it. I'm even willing to pay for an upgrade to better equipment, although I question whether that will be a step up. I am beyond frustrated at this point and really just need some sort of resolution to this issue.

  • Still nothing. No messages from tech support. Ticket was opened Sept 22nd. This is really horrible service.

  • I was able to get my issues solved.

  • How did you get it solved? What turned out to be the problem?

  • Running intot he same issues with iRacing and the CSL Elite bundle for Xbox

Sign In or Register to comment.