Firmware update broke wheelbase

So today I updated my wheelbase firmware becuase I have never updated it since recieving the wheel. Upon installing the firmware very carefully and making sure I did exactly what the installer said my wheel restarted and then it got stuck on this . CAL In menu press both sticks together. Naturally I tried pressing the usual calibration sticks at the same time. This did absolutely nothing. I tried many different things like pressing almost every button together under the sun. So I tried turning it off using the wheelbase button but it still did nothing. The wheel was completely unresponsive and literally nothing happened. I even restarted the PC but the wheel was completely unresponsive to anything I did.

So I turned it off and tried turning it on again. It started booting up, span around to the right then the left and we're now here. It has the first 6 led's lit but not the last 3 and doesn't do anything, i've tried using different USB ports but nothing thats what comes up in the properties page, fanalab only shows the pedals too. I'm completely lost on what to do.

Any help is much appreciated. TIA


  • Make sure your base is in PC mode and not in Xbox mode. Try starting the base without the Wheel attached.

    On newer drivers you can calibrate the center position in the driver itself without the need of pressing a special button combo (which btw only works when you first entered the tuning menu, many people forget this very important step).

  • Thankyou this worked. However, I now have a new problem. When Im on the propertys page and put the rim on it suggests updating the rim. I go to update it but then it just breaks itself, come up with an error, shuts the uploader and decides hey I want to vibrate constantly with a rainbow on the powerbutton LED.

  • Dominic BrennanDominic Brennan Member, Administrator

    Hi Samuel,

    Please create a support ticket via the My Product section of your Fanatec account. The technical team can help you with this.

    [Fanatec Community Manager]

Sign In or Register to comment.