Can't access Elite Load Cell Settings

Just installed my Elite Load Cell pedals and they work fine. They are connected directly to my PC via USB

However, I can't access the setting software without disconnecting my wheel Club Sport V2.5 , CSL Elite Wheel, PC Driver 347, Wheel Base Firmware 669, Motor firmware 22

When normally clicking on FANATEC CLS Elite Pedals LC properties it always only opens the FANATEC Wheel Properties

Disconnecting the wheelbase USB allows me to access the Pedals properties, small work around, but annoying.

Have I installed something wrong?


  • That doesn't sound right. I thought if you had it connected via USB, it should have it's own entry in the settings app. At least my CSP V2's did. I never had an issue where I had to disconnect anything.

    I have my V3's connected via the CSW 2.5 wheel base, as it allows tweaking the BRF while you are in game.

    What happens if you connect the pedals to the wheel base? You should be able to adjust the wheel, brakes, etc. from one menu. To my knowledge there is no benefit to using USB over the R12 connector. (Plus, it will free up a USB port).

    Hopefully someone with a better answer might be able to help.

  • From the product page:

    Max resolution depending on the connection:

    • through CSW B V1 / CSW B V2 / CS WB V2.5 / CSL E WB / CSL E RW PS4: 12 bit (4096 values) on all axes
    • USB direct connection (PC): brake 16 bit (65536 values) / clutch and throttle: 12 bit (4096 values)

  • Yes, this is the reason I connected the loadcell via USB, to get the benefit of the much higher resolution. I did try it for a day via R12 connector before connecting via USB and the differences in my braking abilities was amazing, hence, I want to stick with the USB connection.

  • Have you tried upgrading your firmware. Because when I open the fanatec wheel property tool I can choose the pedals and click on properties when I select the pedals.

  • Same issue, with g29 wheel connected i can not access the pedal property page. when i double click on the pedals it brings up the g29 property page instead. if i disconnect the g29, and the pedals are the only gaming controller, i can then double click on the pedal entry and get the correct pedal property page to come up. driver 3.28 firmware 1.3

  • This fixed it for me. Unplug the g29 wheel, open up the Fanatec settings, then plug the wheel back in. Now the pedals are first in the list.

  • Well, I spoke too soon. Now the wheel is in the second position, I can still access the pedals, but not the wheel. This works for me, since I never use the wheel settings anyway.

Sign In or Register to comment.