Random "false" upshifts and "ghost" button presses

I have been having issues with my Fanatec setup in the past few weeks. I play iRacing on a 64-bit Windows 10 PC - Universal Xbox hub connected to the CSW 2.5 base and V3 pedals. The pedals are using the jack only to the wheel hub, but I have tried the USB also. All using beta v373 driver...but I have also done the standard 328 from the start. Rig is GT Omega Apex wheel stand with rear seat stand and RS6 seat - all on wheels. The problem is the when playing iRacing, random shifts occur (only upshifts - any gear: 1-2, 2-3, etc.) and I get flashing messages on screen which appears to be ghosting button presses for tow/reset. I have that keyed to the RT button on the hub. This happens so often, the game is now unplayable, as I constantly have to babysit what gear I'm in. Shift points vary from very low RPMs all the way to redline. At this point, I've spend many hours of my personal time trying to fix it without success. I tried: different USB inputs, different power outlets, jack vs. USB, moving cables due to potential EMI, etc. etc. etc. I upgraded to Fanatec from Logitec, which I had ZERO problems with running the same setup and settings for 6 months. This happens EVERY time I play and appears to be getting worse...any help would be greatly appreciated! And yes, I submitted a ticket, but wanted to see if anyone else had similar issues for a quick and/or permanent fix.

Comments

  • Sorry man. Can you clarify on something cause I got totally confused.

    You Say

    The pedals are using the jack only to the wheel hub, but I have tried the USB also.


    You have connected the pedals to the wheel base or in the USB jack of the Universal Wheel Hub?

  • Originally used the cable jack from wheel hub to pedals with USB from wheel hub to PC. I have also tried no cable jack connection between the two, but USB from both wheel base and pedals to PC. Same issue occurs both ways.



  • Man sorry. I am totally lost by your description.


    Wheel base is this


    and your wheel hub is this


    Where and how you are connecting your pedals?

  • Correct. I use the  RJ12 connection cable from the base to the pedals...but I have also tried straight USB from both to PC.


  • Does anyone think that this is EMI related? Or no, because its not a DD base? I was going to test grounding the rig...any thoughts?

  • Do you have a second wheel in order to test?

    Might be also the buttons on the backside of the universal hub.

    Or even your button box.

  • No 2nd wheel to test. Everything checks out in the properties application...

  • So I did some more testing...pushed the top 2 button boxes upward, as the flashing messages were associated with those mapped buttons. Ran a few laps and seems to have calmed the problem.

    QUESTION - Could the wires of the top 2 button boxes be getting pinched or moved within the hub to cause this reaction?

  • edited October 6

    I dont want to speak too soon, but I disassembled the universal hub and found 2 issues - 1) the connector for the right shift paddle was not 100% engaged and 2) I found 2 pieces of metal shards within the casing (see pic - pinky nail for size reference).

    After full re-assembly, I tested with normal setup in iRacing and ran 10 laps with 2 different cars on 2 different track...ZERO issues.

    I really wish Fanatec would hook me up with something for doing hours of troubleshooting, spending $25 on products from Lowe's suggested in various threads, and solving the problem on my own prior to their team even responding to my email, but I know that will never happen. Best I can hope for is the problem is gone and never returns so I can be a happy sim racer again...literally wasted 2 weeks of tinkering with dozens of hours of troubleshooting! SMH...or maybe they will hire me!?!?

    I will continue to post if the problem shows up again this week...

    Happy Racing!


  • If this is how you got the HUB delivered to you and you didn't modify the button box connections and/or opened the HUB, in other words what you found is a production issue, then make sure to report this as such to Fanatec.

  • edited October 7

    I will past this info on to the CSR that just responded to my ticket...

  • Been running into phantom button presses (including upshifts) with my CSW 2.5v too, unit was bought May 2020.


    I also get the wonderful fun of having the wheel change itself from PC mode to Xbox mode mid race.


    All iRacing on Windows 10 64bit, tried last 4 versions of drivers/firmware and changing usb ports etc

Sign In or Register to comment.