New CSW 2.5 Wheel base - Red blinking leds on first power up

Hi I am new to Fnatec Products and currently seeing this issue.

Hardware:

New CSW v2.5 wheel base

New Podium Hub with Fanatec drift wheel.


Software in use:


Issue :

On power on the wheel turns left an right and then stopped at center.

The Leds blink red in clock wise direction

I tried updating the firmware Nothing changed except that the wheel stops a little left from the center.

Any connected devices - shifter or pedals son't show either.


Additional Info:

I did check for broken pins. They are all intact.

Driver Version : 328

WB FW Version:628

Any help is appreciated

Comments

  • edited October 12

    Does the wheel connect to the PC after the autocalibration? Does it show the same blinking LEDs if you turn on the wheel base without the rim attached?

  • The driver software shows that the wheel base is not connected after the autocalibration. (Greyed out wheel base with red crossed circle) but when i turn the wheel i can see the position fields change. Thats all i see the pedals and shifter don't change.

    The wheel base shows solid red leds when there is no rim attached. The Driver software still shows no wheel base connected status.

  • This is what i get irrespective of whether a wheel is attached or not.

    The only diference between the two is that after calibration the leds stay red when there is no wheel attached. They blink red in clockwise when there is a wheel attached

  • I didn't calibrate the wheel center, I only have one wheel (podium hub + drift wheel rim) - I don't think they support wheel center calibration. If thats the case i may have to go and buy another wheel or borrow one.

  • Hi Hyde,

    The fact that you are able to open that properties page shows that the wheel base is correctly connected to the PC. The image with the red warning symbol indicates that no steering wheel is detected.

    You need use a newer driver version in order for the Podium Hub to be detected (if you look at the Podium Hub product page, the driver is version 346). But I suggest that you just try to most recent beta, available at the bottom of the first post here:

    https://forum.fanatec.com/discussion/15204/fanatec-beta-driver-v373-372-before-for-csl-csw-and-podium-bases-all-wheels/

    Please uninstall your current Fanatec drivers and install 373 instead.

    This is how I would do it:

    1) Turn off wheel base and disconnect from PC.

    2) Remove steering wheel.

    3) Uninstall current driver. Restart PC.

    4) Install 373. Restart PC.

    5) Connect wheel base (steering wheel not connected). Turn on wheel base, allow it to start up.

    6) Open Fanatec properties page. You should be prompted to update the wheel base firmware. Continue with those steps.

    7) Once complete, open the properties page again. You may also be prompted to update the motor firmware. Continue with those steps.

    8) Once complete, attach steering wheel.

    9) Open properties page again. You should be prompted to update the steering wheel (Podium Hub) firmware. Continue with those steps.

    10) Once complete, you can centre-calibrate the wheel (can be done in the properties page).


    [Fanatec Community Manager]

  • Thanks Dominic,

    I tried to update according to your instructions. But I am stuck on step 6

    I get these error messages.

    Any ideas on what is causing this.

  • I would uninstall and resinstall the driver (start from step 1 again basically). But this time, try a different USB port.

  • Thank you Dominic.

    That finally took care of it. I was able to get past and finish setup after switching to a diffferent usb port.

    Thank you

  • Great! Enjoy your racing! :)

Sign In or Register to comment.