ClubSportPedals v2 throttle stops working properly

When I start up the computer sometimes the throttle will not hit 100% in the properties. I then have to unplug and then plug in the usb cable again. this will reset the pedals but it only works for a short time 10-15 min. I tried different cables, all good quality, i don't use an extension, and still no joy. I have had this problem since I purchased these pedals new but it was only once in a while not Its every 10 - 15 min. The Pedals now make it impossible to compete in online races (iracing) rendering the pedals useless.


  • It's probably your hall sensor. You can try checking to ensure it's on the pedal correctly (Fanatec used to have a video on how to do this, but if you cannot find it....) Ensure the screws are tight, but not too tight and see if that helps.

    If you do not use the clutch, you can swap the sensor over to the throttle. They are the same sensor, and you can just remove the one on the clutch and put it on the throttle. Make sure the cable from the sensor is plugged into throttle and you should be good to go.

  • Joseph GossenJoseph Gossen Member, Moderator

    Have you calibrated the Minimum and Maximum set points?

Sign In or Register to comment.