What am i doing wrong?

edited October 28 in Steering Wheels

I have just received my 2nd Formula V2 wheel, i have not even sent the first one back yet and i have the exact same problem.

I am beginning to think this is a wheel base issue as this time something else showed up in the wheel properties while trying to test all the functions, it looked like the wheel basedisconnected from the wheel or the wheel is disconnecting from the base, either way both wheels i have do the same thing, my BMW GT2 wheel works just fine. I am on the verge of just sending both wheels back and never buying from here again after having and still having issues with my pedals which were certainly not repaired to my satisfaction.

I tried to video the issue, its a quick rushed video but maybe someone can help.



Thanks guys.

Comments

  • edited October 28

    Now This is Happening.


    Remember my BMW GT2 wheel has no issues at all.

  • Hi Neil,


    Can you try to update to the latest drivers ? (either 373 or 374)

    Make sure to unistall older drivers from PC, restart Pc, download drivers, install, restart PC and then update all of your gear.

  • Hi Neil,

    As Alexandros suggests, please update all firmware. If you are coming from a driver package with a lower number than 373, you may be prompted to update wheel base firmware, motor firmware, and steering wheel firmware. You should re-open the properties page after each firmware flash (to check for additional update prompts).

    And if you are not satisfied with a pedal repair, please continue to communicate with Technical Support about this, so they can put it right.

    [Fanatec Community Manager]

  • Hi, in wheel properties i have this:

    PC driver: 365

    WBFirmware: 672

    WBMFirmware: 22

    SWFirmware: 34


    So you suggest a complete uninstall and reinstall, as it is now if i try to update anything it says "my current firmware is the latest version, are you sure you want to continue firmware update." Would reinstalling make any difference?

  • You should try the most recent beta driver, which is currently 373:

    https://forum.fanatec.com/discussion/15204/fanatec-beta-driver-v373-372-before-for-csl-csw-and-podium-bases-all-wheels

    The download is at the bottom of the first post.

    You'll need to uninstall 365 first. Once 373 is installed, you should be prompted to update firmware with pop-up notifications when you launch the controller properties page.

  • Sorry guys but this has not changed anything, uninstalled old and installed new so i now have:

    PC driver: 373

    WBFirmware: 674

    WBMFirmware: 22

    SWFirmware: 35


    Its still the exact same issue, turn the wheel on, go to wheel properties start pressing buttons and everything just stop working.

    No buttons, LED test does nothing, OLED test does nothing, vibration test does nothing, the FFB test does work and the wheel rotation registers, I then connect my BMW GT2 wheel and everything is fine with that so i am at a loss what could possibly be causing this.

    I have sent another e mail and basically if it has something to do with the v2.5 base and that or the wheel needs sending off for investigation and repair its too much hassle when i seem to have one perfeclty functional wheel and base, and i would also be without any equipment for probably a couple of weeks or so, I would rather send both wheels back and get a refund.

    I thank you all for your help, i will just see what decision is made by fanatec on what options i have.

  • edited October 29

    Why I have a feeling the wheel base motor firmware should be higher than your previous drivers. Did you press to update FW and wheel as well in update list?

    For example on my DD that I am using now is 40 but on the CSL and CSW 2.5 cant remember which one was on those, because they are parked in fathers house.


    Also watched again your video and while in menu and your wheel was showing suddenly disconnected and connected again a fraction of a second later.

    Could you check the

    pins?

    wheel is making full contact (inserted in full). you can check by checking if the locking screw goes in properly.

    tight the small screws in the QR connector

  • edited October 29

    Hi Alexandros, thank you for your efforts here, the locking screw is in and tightened up, i have also updated all 3 firmware's and above versions are what i end up with.

    I have noticed a couple of things, this is after turning base off then back on each time it stops working.

    Once the base is on It seems to be that the buttons work ok until i do 1 of 2 things, turn the wheel at least 90 degrees and press buttons at the same time, this just stops all of the buttons working.

    Second thing, turn the base on and wiggle both analogue and funky switches together, this has the effect you mentioned of momentarily disconnecting the base as seem in video, it also has on a couple of occasions so far caused the image of the V2 wheel to change to the CSL Elite wheel, and when that wheel appears all the buttons on the CSL wheel are flashing blue together like i am pressing them all at the same time.

    Third thing is if all of the buttons stop working and i again wiggle both analogue and funky switches together for a second or 2 the buttons start working again, only to stop working as soon as i turn the wheel at least 90 degrees.

    There was one other thing when using my BMW GT2 wheel, everything is perfect on that wheel except the rotary encoder on the funky switch stopped working a few months ago, the directional part of it works just not the encoder, is this a coincidence the encoder on that wheel does not work and it seems to be the same funky switch/encoder that does what i explained above?

    I am out of idea's and patience as you can imagine.

  • One last thing then I am out of Ideas too.

    Did you try to change usb port?

    I know it sounds a bit too easy but other users had reported issues simmilar with random freezing or disconnecting wheel on the V2 and this helped them solve it (or something with the pc stuff on the USB side)... 🤯

  • Just tried it Alexandros and no luck I'm afraid.😕

  • Hi Neil,

    It sounds like there could be an issue with the wheel base connection. The Formula V2 contains much more advanced electronics than the BMW GT2, so it is not that unusual that the issue was not apparent before. But it's not the only possible explanation. Our tech support will do everything they can to help you with this. Unfortunately they are dealing with a large backlog of enquiries at the moment so it may take a few days between responses, so please supply as much information as possible (but also explained as clearly as possible) in a single message.


    [Fanatec Community Manager]

  • Hi dom, had a reply to suggest tightening up the screws in the wheel and wheel base hub, i was afraid of overtightening as the instruction was finger tight but it seems to have worked as so far half an hour of racing and no problem yet. I just hope i have not over tightened the screws as finger tight was a specific instruction and it maybe seemed a bit more than finger tight.


    Anyway big thanks to you and Alexandros for all your help.😎

Sign In or Register to comment.