Last Digit not displayed on F1 eSport Wheel

Opening this thread shall a user already had this issue and has an idea if and how it could be fixed as I'd love to avoid sending this brand new wheel back (I have no other wheel so I just won't be able to play). I also can't find anything on the web about this problem.

A ticket has been opened with the support and I will update this when it get answered so it can benefit others

To put it short, the last digit is not functionning anymore (it worked fine the very first day, but the day after it was gone). Everything else works properly (and I'm having tons of fun!), it's really just a display issue.

Using the display test tool confirms the last digit is "dead"

Firmware has been updated (last official, then last beta) but this does not fix the issue, reboot and resetting the wheel is not fixing this eiher.


Thanks

Comments

  • Have you verified the connection is good between base and wheel? screws and pins are not loose or bent? If this has been checked then it is best to wait for support follow up.

  • Yes, and everything seems fine, moreover everything else is working perfectly.

    I suppose there is a minor defect somewhere inside, bad luck for me. I've sent pictures and a video to the support. Although I really hope we can find some kind of way for me to fix it myself, I'm afraid there will be no other option than send it back...

  • If you've opened a ticket then that is the best option and I would avoid trying to fix it yourself.

  • edited November 6

    I opened a ticket on Oct 30, received a request for picture/movie few days after, answered and sent pictures plus movie right away...and no news since then.

    I must say it's really quite slow unfortunately

  • Update. Since yesterday, the wheel is working fine.

    I have no clue what happened. Nothing has been moved/changed (wheel was not unplugged and plugged again, playseat was not moved, I mean the whole thing did not move the slightest, no update or whatsoever).

    The last digit just magically returned when I booted the base for a quickplay, and this is after days and multiple playing sessions with the issue remaining. This morning it's still working fine.

    This is really strange but for now it works. I received a RMA to send back the wheel, I guess I will wait few days to see if it happens again and if it does I will send it back

Sign In or Register to comment.