CSL Steering Wheel will not show up on NEW Clubsport v2.5


Below is my case notes to Support. Bottom line, my wheel was working for a day on my new clubsport v2.5 base, and then the next morning the shifting gears went crazy on iracing. I took the wheel off to check the pins, and everything was fine. I put it back on, and the wheel was not working. Any Ideas?

Latest firmware - 347m w/ matching firmware.



When I first got the base, yesterday. I had this problem. I fixed it by loading driver 311. The I uninstalled 311, rebooted, and installed driver 328. I was going to update the firmware, but I got a message telling me that I would be downgrading the firmware. So I left it.

Now, the wheel base is not being seen by computer. When I look in the Fanatec wheel driver property program, nothing shows up. And I can not turn it off by holding down the power button. The steering wheel(CSL Steering Wheel P1 for Xbox) does not indicate any function at all. I did check my USB ports, and they all work fine with mouse or keyboard. I did try the beta driver 347 following these steps. Uninstall current driver

Restart PC

Install beta driver

Restart PC

Switch on wheel base.

Last night it was working fine with driver 328. This morning, in Iracing, I noticed my shifter would not come out of first gear. When I try to re assign, the down shifter icon on the program was flashing, as if something was holding down the shifter. I was able to see the Wheel base in the Fanatec program, but the display and light test did not work. I shut down the wheel base, and computer. Removed the steering wheel to check the pins. Everything was fine. When I booted back up, I'm having the current problem.

I removed the steering wheel, and the base showed up on PC. I was able to load beta driver 347, and update the firmware. Everything worked fine. I inspected the wheel, and the pins were fine. I also made sure the module contact was secure on the base, and in the steering wheel by a hex tool. The wheel base is in PC mode, red light ring around power button.

What is my next step? The wheel was working just fine last night.

Sign In or Register to comment.