CSL Elite not Working

I have the CSL Elite and it worked fine. It said there was a firmware update so I decided to do it but after 3 hours of the bar not moving, I canceled it because it wasn't doing anything. Now the wheel base is stuck in update mode, it cant turn off, it still wont flash firmware and IDK what to do. Fanatec dosent have a customer support, and if they do, they hide it well. I cant get the base to do anything.

Comments

  • Hi Andrew,

    If you can't turn the base off normally then you should cut the power by disconnecting the power adapter. Then close the firmware updater on the PC. Reconnect the power, press and hold the wheel base power button for 10 seconds, so it starts in boot loader mode. The firmware updater should pop up on the PC.

    If that doesn't work you could try a different USB port, or a reinstalling the drivers, or trying to update using a different PC.

    If all of that doesn't work, please open a support ticket. You do this by logging into your Fanatec account, going to the My Products section, and clicking the 'Support' button next to the relevant product. If your products are not listed there, you may need to manually register them.


    [Fanatec Community Manager]

  • Updated firmware today and no brake pedal doesn't work ???


  • Have you tried reconnecting the RJ12 cable to the USB adapter? Or using a different USB port?

Sign In or Register to comment.