Dd1 problem with failed firmware Update


my Fanatec dd1 failed a firmware Update.

now when i plug in the power socket the fan starts at 100% and the wheel turn 180*. Screen is Black, no connection on usb, and power butten is not doing anything.

have any of you tried something like this?

what to do?

sorry my english is bad, hope you can reed and understand what i mean


  • Joseph GossenJoseph Gossen Member, Moderator

    Not recognized in the Fanatec driver window either? Have you tried starting the base with no wheel attached? If you've tried this and it is still not responding, you will have to open a support ticket through "My Products" page.

  • sounds like the update didnt finish. after you flash firmware it should say updated successful then it should tell you to go to control panel settings and do the Motor calibration( remove rim and shaft will turn slowly CW then CCW), after that it will say finished and tell you to unplug etc. If it didnt say finished and tell you to unplug it probably wasnt done yet.

Sign In or Register to comment.