Random button presses or wheel disconnects

Hi, I have a V2.5 base with CSL elite wheel. I returned one wheel on a RMA with this issue and they replaced the wheel with a new one.

Now after a couple of weeks I have the same issue. After 2 hours or so of using the wheel suddenly acts as if random buttons are being pressed or disconnects to Xbox mode.

The only solution is to remove and replace wheel onto the base. Then it's good for another couple of hours.

Also the replacement wheel I could feel understeer for the first time. I could never get this to work on the original wheel. Is this just a general bad quality issue?

I have not made any firmware updates etc. All was fine then just suddenly the problem is back.

For £1000 I expected more than this.

Starting to wish I'd never upgraded to Fanatec.

Thanks for any offers of advice.



  • You write you didnt made any firmware update. But you should.

    Give driver 381 with firmware 680 a run, it fixes a LOT of freezing issues and something like you report.

  • Thanks for the reply.

    I will give it a try but don't understand how it was fine and then just suddenly starts failing.

    As I said, the last time this happened Fanatec confirmed the wheel was faulty with the same symptoms.

  • Just an update, I have tried the 381 driver and 680 firmware but the problem is exactly the same. In fact its getting more frequent . I have now a brand new PC and the problem is still the same. I'm in contact with fanatec but takes a while between emails.

  • The conclusion to this fault. Had to send away on an RMA for the second time. Can't complain about the service but now I've had one faulty wheel and one faulty wheel base, and all for only a £1000. Just not worth the hassle. I've now 'upgraded' to a £300 thrustmaster. To be honest not much difference. Won't be recommending or buying Fanatec again. In fact I will actually advise people to avoid their products.

Sign In or Register to comment.