Best way to flush all prior usb device config?

Hi, something's happened with my fanatec wheel - it now shows up as a different device -

The bottom green one is the default profile I loaded, this has always worked, until today.

The Top yellow throttle one shows a 2 after it - this is after I remapped the throttle manually (I also manually remapped the steer and brake)

I suspect something got messed up with the driver/USB in the registry - I'll uninstalled/reboot/reinstall the fanatec driver, but wonder if there's anything else I need to cleanup.

- Jack


  • Found a few resources for this if anyone finds this post.

    #1 - open windows 10 control panel, Then devices and printers. I did a "Remove Device" on the CSW 2.5 on the bottom under the "unspecified" category, Then I connected the 2.5, and it showed up with a F logo under the "Devices" category and I did a "remove device" on that too, then rebooted, re-attached device and it showed up normally - ACC, RF2, both worked perfectly after this.

    #2 Nirsoft UsbDeview - I believe I've seen this tool mentioned in the past, could be an alternate way to remove drivers for a USB device. I did not need to use this to fix my problem but wanted to include it for reference.

  • This mostly happens when you connect your base again but in a different USB-port. More game will see it as a different device when you use a "new" USB port.

    I had this problem in iRacing in the past. But it was easily solved by just changing back to the previous USB-port.

    There was no need to clean drivers or tools to clean drivers.

Sign In or Register to comment.