Wheel Base v1.1 no power

Spent the weekend setting up my SIM racing system only to have it end on a very sour note. My wheel base will not turn on, pushing the button does nothing at all. I searched for over an hour for a solution and found numerous other racers have had the same experience, but I found nothing that would fix my issue. My best guess is that I was shipped a bad power supply which is really irritating! If this is a known issue why aren't these things quality checked before being shipped?


  • Dominic BrennanDominic Brennan Member, Administrator

    I'm sorry to hear that Brian.

    Are you seeing a light on the power supply?

    [Fanatec Community Manager]

  • No there is no light on the power supply.

  • Dominic BrennanDominic Brennan Member, Administrator

    Please open a support ticket via the My Products section of your Fanatec account, explaining what you have tried, and that there is no light on the power supply. The team will arrange a replacement as soon as possible.

    [Fanatec Community Manager]

  • I opened a ticket yesterday, hopefully that will be seen soon.

  • Still no response. :(

    As soon as possible is not soon enough for me and the complete lack of communication is totally unacceptable! The investment made in Fanatec gear is way too much to be held up by a made in China power brick!

  • Brian NankBrian Nank Member
    edited December 2020

    Spent over $1000 to buy Fanatec gear that I am still unable to use because of a $5 China power brick!

    UNACCEPTABLE! You have lost a customer - I will not purchase another Fanatec product until you improve your internal operations!

  • Brian NankBrian Nank Member
    edited December 2020

    Still no replacement power supply for my $1000 fanatec investment!!!

    Support is pathetic!

  • Replacement Power Supply arrived today and it works! Finally I can race!

  • It took Fanatec 2 weeks to get a power supply to you? Are you domestic US?

    My power supply went out a week ago (on a Friday evening of course). Fanatec jumped on it pretty quick with the RMA etc., but no shipping notification or tracking number yet...

    it would be nice to get 2 day tracked shipping when you’re dead in the water after spending $2k on equipment from them. But I suppose Fanatec are small and do not get the same economies of scale when compared to companies like Dell.

    FYI, this supply failed after 2 days, and powered down just sitting there in the pits. Never lived again!

  • Update on my deal:

    I notified Fanatec on Friday Dec 18th

    Ticket created same day.

    Email on Saturday Dec 19th saying the power supply would be sent ASAP.

    Arrived via UPS Thursday Dec 24th.

    With the holidays etc, that’s pretty darn good. And the initial response over the weekend was also good. Just note that I didn’t get a shipping notification or tracking number. And the supply came without a cord - so keep hold of yours if you are shipping it back, I didn’t and scavenged one from something else.

    good job Fanatec.

Sign In or Register to comment.