Crushed Throttle Cable now no signal

Hey all as per the title i somehow managed to pinch the throttle cable on my csl elite set between the pedal base and my rig. last night while driving in ACC i all of a sudden had no gas. so i pitted thinking i ran out of gas or something silly (free practice session) however i couldn't pull out of the pits.

I exited to windows and opened up the fanatec software to see if it was getting input. it was not. my brake and my throttle both wont work since i pinched off this cable. I'm curious if others have experienced this before? it seems weird to lose both throttle and brakes for a non shared wire.

I know this is my own fault i did however contact support as well to see what they say. but if i can DIY a fix i'd be all ears to know what i can do / if anyone has had this issue before.

i tried to swap the cables from gas to brake and vice versa in software and re-seated all wires in hopes but didn't get any signal from the pedals. so it seems im sidelined for now thanks in advance guys. really appreciate it! (the wheel itself seems 100% all buttons register FFB is fine etc)


  • It sounds like you're going to need a replacement throttle cable+sensor, however I would try to fix the cable myself anyway.

    First check if the cable came loose at the soldered connection on the sensor board, that's easily visible and also relatively simple to fix with a soldering iron.

    If the connection to the sensor is fine then the cable is probably broken somewhere inside. You'll then have to open the cable by carefully opening it up, finding where it broke and soldering the ends back together again. If there's a clear spot in the cable where it was pinched then that would be the place to strip the cable and find the broken wire(s).

  • thanks for the reply! so the crushed wire was a bit misleading and not my issue i did manage to correct this and will leave my case open with support. basically the crushed cable wasn't so bad that it is broken. i found out this morning when i bench tested everything off my rig that it was working again .... with a few more tests it seems like the RJ12 cable from the wheel base to the pedals itself is the issue. it needs to be just right or it wont work. i think there is some sort of internal damage in this cable as its all fine now but the cable needs to be positioned just right or it will flake out on me again.

Sign In or Register to comment.