DD2 and F2 rim

Tried new car in iRacing and it worked this morning and drove 4 laps without problems. Had another go and when I tried to drive out the Fanatec Firmware updater appeared so I stopped the game and saw the "Mode: wireless quick release" in blue and after hitting connect got in message logs

Wireless Quick Release Update Mode

Error: Connect Device Failed ( Error Initial Ping failure: no response received for ping command }



  • Unfortunately, the DD2 is turning out to be a real piece of junk, especially for the money paid. I have a DD2 and it worked for exactly one day. Then it went into blank mode and it basically is doing what you are describing. I have followed multiple threads looking for an solution, but none have worked for me.

    I have gone back to prior versions of the firmware, but no matter what I do, I cannot find a solution. I can get the DD2 to at least boot up using any version of firmware that is not 380 or later. In all cases my motor firmware version is always 0.

    If you are waiting for customer support, be prepared to wait a long time. I imagine they are swamped and it is pretty much radio silence.

  • I have had my DD2 for over a year and its worked good but then it just started doing what I posed...I think something in the wireless electrical may have died. It was working fine, this morning did 4 laps at Spa and after lunch tried again and gear shifter wouldnt work and I thought it was something in iRacing new UI so went back to the old one and thats when I got the message

    Put my Porche rim on and when pressing it on I had part of my hand on the carbon fibre shifter and broke that ....but the main thing was that didnt work and got the same message

  • Hey WIll, whats the update on your situation? ive got the same issue today after just over year of good use. Cheers mate.

  • Well the Australian repairers are on holidays until 10th Jan and then I will contact them on the 8th Jan again and get a RMA .........before all that they got me to update to the latest drivers and remove everything to do with fanatec through device manager and view devices by container and view hidden and remove all fanatec. Didn't work and when I got a replacement CSW2.5 and put the V2 rim on it worked straight away....I believe it's the wireless transmitter that failed. So now next year it will be a RMA with a Transport Company picking it up as its way to heavy to carry down to the Post Office ...I think that may cause an argument or two but I don't have a car anymore

  • Thanks for the reply WIll. Ive put through a Request for support last night.

  • i have also exact problem have been in touch with support they asked for serial number so i can send back went to turn on computer after 10 days of constantly going to forum trying everything but to no avail THEN ALL OF A SUDDEN OUT OF THE BLUE IT CONNECTED [but only lasted two hours] then back to no connection. This morning as i am writing this out of the blue it connected again ? i did nothing as i write its connected for how long i don't know?

    Wireless Quick Release ping no connection shows up

  • It could be as simple as a loose connection but I don't think Fanatec want us pulling it apart. They told me to go to device manager and in View select Device by Container and Hidden Devices and remove any thing Fanatec

    Its not good knowing it works and then it doesn't but in the end the truth is its not working as it should be and needs fixing.

  • yes i got that too had to make sure all deleted

    i cant help thinking its a loose wire as well

    my conection has gone again it lasted approx 1 hour,,,i got a race in was good fun while it lasted

  • well my unit is on the way to get fixed

    currently on the way to Casino before going to Lismore

  • Any updates on this? @Will Sutton?

  • Will SuttonWill Sutton Member
    edited January 2021

    Just the message that they received it(a week ago ) ..... now its wait and wait

    Now what would be nice if Fanatec had a system that kept you up to date

  • So my DD1 just died in a similar fashion. Used it the other day no problem. Tonight boot it up and my endurance Porsche wheel isn't responsive. Try updating my firmware only to have the wheelbase start to not be detected by windows. Now the only thing I'm left with is the firmware updater telling me the same "error: connect device failed" message. Seems like the electronics inside the DD1 handling communication both the PC and the wheel rim have died? The wheel powers on and off fine, but that's it.

  • well Fanny responded and told me my base should be back this week ... I doubt that as I think its the standard response they reply with

  • +Ive been getting this same error, and my formula v2 just is no where to be seen, any iodeas on this_

  • Will SuttonWill Sutton Member
    edited January 2021

    It could be a part that is failing , something to do with the wireless signal maybe but I doubt that Fanatec will say what the problem is

    Now it could be that its taking so long because they need to get a part in to fix it.....or they are snowed under with stuff to be fixed in Australia

  • I've tried everything so I think it has to be hardware. Submitted a ticket the other day but haven't heard back yet. If anyone has any information about this problem it would be great. Hopefully this isn't some sort of widespread hardware issue that hits after awhile.

  • well they will most certainly tell you to clean out all fanatec software and install the latest release as can be seen in my earlier posts......maybe follow those instructions now so you can tell them that when they ask you to do this

    I am getting mire pissed.....they said I would hear this week but nothing

  • Ok, they are not saying what was wrong with my DD2 but it has been picked up for delivery to me. The sad thing is they left my FLAT number of the address but the real sad thing is they put the Suburb of Gwynneville as my address and I have never lived there. God knows what is going to happen

  • Ive recieved my back, works great again. however there seems to be a washer jammed between the frame and the OLED. might have to send it back. just waiting for a reply on what to do with it. Hopefully they will just walk me through opening it if the removal is easily done.

  • well finally arrived back today and it's working ok ... still mid-December to 12th Feb is not a good time frame

  • DD1 Wireless quick release still showing up, sent back because of this problem

     nobody wants to admit there is a problem at Fanateci have been without my DD1 since Nov 2020,got an RMA sent it back received it back you can see they put quick release new on base, no notes of what repairs was done or the problem,mounted it up all excited and you wouldnt believe it ! same problem shows up,turn it on turns to right only and then shuts itself off and this message comes up againi am so pissed off right now, sent an email a week ago letting them know its still broken and no response yet? i live in hope?they got to know of this problem and yet i get questions like they never heard of this problem before ? either they dont read problems on forum or just dont know how to fix itI got so Pissed off i borrowed money off my wife and bought a second one spare its supposed to arrive on the 18th feb...i wander if its going to work?if i does i am going to insist on a replacement for my old one as i believe they dont know what the problem is causing this and i can see im not the only one with this problem

  • Older thread but I give it a try. Since today I'm also getting the same error message as the above picture. WOrked for about one year without any issue. I followed all suggested steps and even tried on another PC (laptop actually) and also older firmware/sw version 3.56. Then the DD1 wheelbase display works. When (mandatory) updating to the latest version 4.02 the display shuts down and all black. Both with the older and newer version software drivers the steering wheels are not detected anymore. (CS Formula v2, McLaren GT3 v1).

    I received good and quick response via chat and mail today. Now uploaded a video with the symptoms. Waiting for the support answer but guess I have to send the DD1 wheelbase to their workshop for testing/solving the issue?

    Did anyone else solve this without having to send it back to Fanatec? Not sure it seems the wireless connection has been 'broken'?

Sign In or Register to comment.