V3 pedal suddenly not detected

I got the V3 pedal since July 2020, and everything works well until tonight. When I got home I started Iracing to try the new Lambo at the Long Beach, but the pedal was suddenly not detected by my PC. I initially thought it was the Windows issue so I restarted the computer. And still not detected. I then tried connected the pedal directly to the PC thru USB (it used to be connected to DD1), and still not detected. I have reinstall the driver and reboosted the PC for several times, and nothing changed. I tried every usb port on my gaming PC and my working labtop, it was still not detected.

I have no idea why this happened. I didnt do anything to the pedal. It worked normally yesterday and it was just sitting on my rig and nobody touched it. Anybody please help!


  • Yeah, man! My CSL Elite LC pedals suddenly stopped working as well. The Properties page opens Windows Game Controllers for some reason...I uninstalled, reinstalled drivers, tried different USB ports and....Nothing!

    Something is very wrong here...

  • getting the same problems aswell

  • Sane here. Mine just suddenly quit working this week. Doesn't matter what P.C I plug them into they are not recognized. Does anyone know if maybe the cord could go bad.

  • I just got everything setup yesterday and it all worked fine, but then i started getting the pedals disconnect mid racing. Tried multiple games, same results.

  • After reinstalling EVERYTHING including windows twice I realize sadly my pedals are also not being recognized. This sucks - now what?

  • I am so disappointed to fanatec. I am new to sim racing and I got the best gears from them, and within the past 5 month, I have been dealing with wobbling of the podium hub, crackle noise from F1 wheel QR, and now dysfunctional pedals out of no reason. It sucks. I just ordered a set of heusinkveld pedals but I dont think I will get them until next year. I am so sad that I cannot race during this winter break. I will replace my DD1 with SC2 soon. No more fanatec.

    Best luck to all of you.

  • I've had my V3 pedals since late 2016 and haven't had any problems (except for re-greasing when squeaky, but that's normal). Just updated to 399 beta driver, updated all firmware. there's also a firmware update now for the V3 pedals, but you have to update them using the USB cable (I have mine connected through my DD2). I followed instructions and disconnected RJ12, went USB to PC, and it froze up during the firmware flash. It Said it may take several seconds, but after a minute or two I decided it froze so I closed it. Now the pedals aren't recognized at all (USB or RJ12). I even went back to driver 381, V3 pedals were still not recognized. This is the first time the pedals had a FW update, going back four years when I first got them. I submitted the issue to support, waiting on word back. Maybe a pcb board replacement will solve?

  • @Jesse

    I am having the exact same issue as you described. I closed the app during the firmware update and now windows is not detecting my pedals at all. Did you ever manage to resolve this? Please let me know.


  • Same for me! Pedals are dead for my PC now...

  • Has anybody had this problem solved yet.

    I now have a bricked set of pedals as a result of the latest firmware update where it sits with the Message Log Box showing "Erase Started (may take several seconds)"

    They've only been used for a few hours so this really sucks as I now have to go back to my Thrustmaster set where I've never had any problems.

  • I solved this shortly after posting............

    My problem was the pedals were working fine prior to attempting to update the firmware but I did have a 1 meter USB extension cable plugged in as I just purchased a larger desk.

    With the USB extension cable unplugged, the firmware update automatically continued and succeeded in seconds so, my bad.

    The extension is back in use but I will remember to take it out next time I receive an update.

    Fanatec support did respond extremely quickly to a support ticket I created which was fantastic even though as it turned out, I didn't need their support.

Sign In or Register to comment.