Left thumb encoder not working as expected

Hi community,


I've been using this Wheel for almost 1 year now and I've been using it on XBOX. However, few days ago I bought a PC and started using it on my new PC.

While trying to config the buttons, I found that the left thumb encoder is not working as expected. Initially I thought it was something related with the game, but them I opened the Fanatec Software and I could see that the input/movement is not recognized by the software as well.

I recorded a video which I think will help to identify what's going on.

Did you guys face any similar issue before?

Thanks in advance

Comments

  • Does the rotary feel loose compared to the right one?

    Does it work in game either on PC or Console?

    Have you tried updating the SW FW again?


    Please contact support otherwise.

  • Hi Joseph,

    Thanks for your reply.

    The rotary does feel the same as the right one. Nothing different. I don't think there is any loose cable as well, because I never opened/dropped the wheel.

    I never used them on Console, because XBOX does not support. I just figured out this problem because I bought a PC and tried to setup the wheel.

    I didn't try a software upgrade (I will, just in case).

    I've also opened a case with Fanatec, 2 days ago, but decided to reach out to the community to see if anyone else experienced a similar problem.

  • Good that you sent a email to support. Let me know if the Steering Wheel firmware update helps.

Sign In or Register to comment.