CSL Elite PS4 buttons, shifters and LED problem

edited December 2020 in Steering Wheels

Hello,

two days ago, while I've been playing Iracing, up shifter stopped to work. One minute latter down shifter stopped to work too. I reloaded the game, the problem remain, plus my exit button didn't work.

I repeated the same process of game reloading without any success.

In the next few minutes all buttons stopped to work, and LED lights disappeared.

Since then I tried every solution I found on the internet:

  • reinstalled drivers
  • delete current drivers and installed older version
  • change USB port
  • disconnect the rim from the base and put them together again
  • delete Windows update
  • connect the wheel to other PC
  • etc etc

Nothing worked for me at all.

It's less than 3 months old , I didn't touch anything since I mount it.

I never used FFB stronger than 5 , so it can't be the reason.

In the wheel configurator I press LED display check, but nothing is happening on the wheel display.

I contacted Fanatec support, and I'm waiting for their answer.

It's just sad, as I really enjoyed in using this wheel, and I was considering an pedal update, but I'm not so sure now.

Has anyone had similar experiences ?

Regards ,

Borna

Comments

  • Sorry to hear that Borna. Looks like you have checked most options. A couple of other things you can verify.

    • Are any of the buttons registering at all in the Fanatec Driver window?
    • Did you check the screws and pins inside the steering wheel and wheelbase to make sure they are tight and/not damaged?
  • Thanks for quick response, Joseph.

    Steering wheel LEDs test - nothing is happening. Segment display test too.

    Only when I press Wheel Base RevLED test, I get lights on the wheel base LED screen.

    I'll attach two pictures of pins. One is from steering wheel, and other from wheelbase, so you can possibly check if everything is in place.

    Regards,

    Borna

  • two pins of the steering are broken it seems, please contact the support.

  • Thank you for the response, Sascha.

    It seems I have 11 pins in the steering wheel, instead of 13.

    Where those two could have disappeared ? I couldn't find them, unless they were gone into the wheelbase.

    Will it be complicated to fix it ? I just hope it can be fixed, because this wheel is ten times better than any other wheel I owned in the past 15 years.

    Regards,

    Borna

  • Please make sure they aren't stuck in the baseside QR, otherwise I doubt they will fix it, they will more likely send you a new unit.

  • I will try to arrange to send everything back to Fanatec for the repair. I have all original boxes and parts, and I don't want to broke something. I'll pay transportation fee if needed. It is still very odd problem, because I attached wheel to the base the same day I received it, and didn't moved it from the base since. As any customer who experienced fail in his product, I'm little suspicious now , but it will gone with first lap after they repair it :)

    Regards,

    Borna

  • They are stuck in the wheelbase QR as you can see in the first pic


    Please open a support ticket through your account under “My Products” tab.

Sign In or Register to comment.