CSL Elite 1.1 - Unknown USB Device

Hi all,

I'm new to Fanatec and the last wheel I owned was a G27 ages back. But I'm currently running into issues with my PC (Win 10) not recognizing my CSL Elite 1.1 Wheelbase (M3 GT2 rim and clubsport shifter connected to the base).

I also have the CSL Loadcell kit pedals connected separately through USB and the firmware and the pc detect the pedals just fine. With the wheelbase, I've swapped to different usb ports, uninstalled the driver in the panel and tried numerous firmware versions to no avail. I have even tried connecting to my second pc and downloading firmware but the wheelbase wasn't detected on that pc either. Could this be an issue with my wheelbase?

Strangely enough there were two separate occasions where the wheelbase actually connected and registered, the first time I managed to install a wheelbase update but then the wheelbase returned to being an unknown usb device. The 2nd occasion was when I was trying to connect the wheelbase and it registered as the CSL Elite correctly. Although in device manager and control panel, the CSL displayed an exclamation mark (control panel states this is a driver error). I should also note that the second recognition of the wheelbase came after I downloaded and installed a win10 update and freshly installed v347 firmware, this didn't last long though...

I have tried numerous methods from usb inputs, uninstalling drivers and reinstalling different versions, trying to connect through bootloader mode (still displays unknown usb device), taking notes of the order I startup the wheel, connect and power on with & without rim attached, connecting the LC CSL pedals to the base instead of usb and startup, trying my second computer. All with no success.

The only glint of hope I could gather was that v347 seemed the best as the two times the wheelbase was recognised was running on the v347 program/firmware. Though it seems now all the versions I've so far tried will not help. v347 included.

I have reached out to fanatec's support and I am also reaching out to you guys as I am losing my sanity spending 12+ hours restarting, plugging and unplugging.


Sign In or Register to comment.