Pedals not working/not recognized (CSL Elite PS4 and Loadcell)

Hi, everyone!

I need help with my CSL Elite PS4 wheel and loadcell break. The pedals are not working and not recognized by the wheelbase. The pedals are recognized in the Fanatec page on the indicator bars only when connected directly via USB to PC. When connected to the wheelbase the pedals are not recognized and movements are not indicated on the bars in the Fanatec page.

PS4 does not recognize the pedals niether via USB nor via the wheelbase connection. With the loadcell I got a second comm box at the pedals (1 original with gas and break sockets and 1 with gas, break, clutch sockets). When using the normal box the pedals are recognized by PS4 in Gran Turismo Sport, but act as handbreak and something else, totally unrelated with gas and break. When using the loadcell box the pedals are not recognized at all.

I flashed firmware 4 times trying with both 346 and 381 versions to both pedals and wheel, I tried all sorts of restarts, reconnections, etc with ZERO results.

After re-assembling everything 3-4 times and checking all wires, my suspicions are: 1) firmware issue in the wheelbase 2) connection issue in the wheelbase or the OEM RJ cable between pedals and wheelbase

I have not been able to reach Fanatec support for 3 days now and look for your generous help here.

Thanks,

Georgi

Comments

  • edited January 15

    In order to uses the pedals in console have to be connected throught the base only.

    a) Dont mox and match the electronic boxes. Totaly different electronics. Maybe this is why it is recognized as a hanbrake when you connect the LC pedadal to the non lc pedal box.

    b) Connect the LC pedal box via USB to the PC and run their driver under the product page for LC Loadcel check if latest.

    c) If you have time assemble the pedals back to non LC stule and connect to the wheel base. If recognized then your RJ cable and base port is ok, which means the issue might be in the LC electronic box, or LC pedal pressure senson.

    Is there any possibility that when you were trying to upgrade the drivers you had the LC pedal electronic box both in USB to pc and RJ12 to base?

  • Hi, Alexandros. Thanks for your comments. I have already tried what you suggest.

    Yes there is a chance that the LC pedal box was connected both in USB to pc and rj12 to base. What do you think?

  • edited January 15

    If they were, You might need to contact support cause when you connect both at same time you might burn the PCB (the electronics box).

  • Thanks. I hope this is not the case. It's also very disappointing if such issue was left in a high end product when it could have been prevented with a simple switch.

    Fanatec Support are not answering my calls and emails.

    Again, thank you for your feedback.

    Cheers,

    Georgi


  • Well it clearly states in manual to be carefull and to connect either usb or Rj12 but never both ways to prevent damages.

    Register a support ticker through your account in your products.

    Again this might be on off the reasons. Better troubleshoot as above (convert back to non LC pedals to check the rest. Cables, ports, base etc) and if all work then try to update only the LC pedals connecting in pc without them being connected to base or base turned on.

    Make sure to have videos for all your trouble shooting to upload on your support tickets because support will ask them to understand the issue and will help to reduce the back and forth emails which take time.

  • Hi, Alexandros,

    /faulty rj12 socket/ I thought about the same steps for trouble shooting. I started back from the beginning following the exact order of connecting staff and first flashing firmware. I started without LC pedal. I was lucky to spot my pedals briefly coming to life as I was connecting the rj12 to the wheelbase.

    It turned out that the "pedal" rj12 socket on the wheelbase has either a loose connection or is a bit wider than the cable. The cable does not make the correct contact inside. I found a temporary solution pintching a small piece of wire to hold firm the cable inside the socket and enjoyed few hours of sim racing as a relief.

    I am checking the LC now and tomorrow will be sending a new ticket to Fanatec. Unfortunately I see this going into a return for check and repair of the socket or me risking to keep it like this and dealing with my temp solution.

    Thanks for your advise. It was really helpful.

  • Hi Georgi happy to be able to help you and I wish my help would end up without a temporary solution so you can enjoy more your gear uninterrupted. Continue speaking with the support so they can sort you out as quick as possible.

  • Neil CollinsNeil Collins Member
    edited February 17

    Hi Im asking this on this section as I dont really know where to post it.

    I also have a problem with my load cell pedal set not working.

    I have raised a ticket but three days have passed with contact from Fanatec, just wondered what is the average response time please as I want the pedals working again ASAP.

    Many thanks

  • I have exactly the same problem with my CSL Elite. Because it is a PS4 version you have to connect the pedals to the wheelbase. The pedals socket is now tired and feels slack when I insert the jack compared to the other three. On closer inspection the 3 good ones have the 6 wires well down in the socket. The pedal one has the wires half way up to the top, so they have lost their springiness. I suspect the yield stress is being exceeded every time the unit is connected due to poor copper quality.

    My connection started to fail occasionally after only 6 months. It's now out of warranty and Fanatec want me to pay for a repair to an item that was never fit for purpose. I will pay to get it fixed but I am considering claiming the fee back through the court system. As usual companies know they have a problem with certain stock faults but they try to keep things quiet.

Sign In or Register to comment.