McLaren GT3 V2 Shifter Issue

Hi all,

Just received my McLaren V2 rim, put it on a CSW 2.5 base, and the shift up (button 5) is showing as constantly engaged.

I can't map anything in ACC because it sets straight to button 5 as soon as I click anything, I've attached a picture of the Fanatec wheel property page showing the shifter button illuminated with no input from me:

I've tried reinstalling the drivers a few times, unplugging the wheel base, reconnecting the wheel... every time I connect it the shift up paddle is showing as active all the time.

Am I missing something or is this going to be a customer support job?


  • I should also point out that the left shifter works fine, it shows here that both are engaged when pulling the left which should be impossible on this wheel

  • Sounds like a physical switch connectivity issue. I would contact Fanatec support.

  • Same thing here. Got my wheel January 5th. Worked fine last Friday. Saturday race, standing on the grid: no upshift. Needless to say, I got nowhere.

    Case opened with Fanatec support.


  • I opened a returns form on the 8th, and they have given me an RMA number today. DPD are supposed to be collecting it from me tomorrow to send to the UK returns warehouse, after which a replacement will be sent out to me.

    I'll update this as it goes in case anyone else has the same issue, hopefully this isn't a repeat of all the trouble they had with the V1.

  • I had a similar issue. I received it 2 days ago. Seemed to be working fine at the beginning. Then after an hour or 2, the shifts starting missing. First just every now and then, but then it got really unbearable. Now, 2 days later, I've tried it again and it seems fine again. Tomorrow I will have a longer session, to see if it starts acting up again.

    Please keep us updated! I will update here as well in case someone has a similar issue.

  • Took five days to get an email from the support team.


    Could you please provide us with a short video or a picture of the problem?

    This would help us in confirming the issue and would speed up your case.


    What??? How could a video show or illustrate ANYTHING that it is NOT working?

    They must be out of their minds....

  • It means whenever you get the problem you are describing to suppot, shoot a video and sent to them.

    For example on initial post saying that the button was always showing pressed the op must have made a video showing the same in the fanatec app.

    OR like in your case show them on video that even if pressing to engage gear to show them that nothing happens in game and on the fanatec drivers app on PC.

  • Update:

    The new wheel arrived today, everything seems to work OK from what I can see.

    If I can offer any advice to anyone reading this with the same issue, it is to provide as much evidence as possible in you initial claim. Every response from customer support will take at least 4 working days, so try and get ahead of any questions they will ask, and provide them the answer first.

  • To put a real twist on this issue...

    After another round of emails with Fanatec and trying version 402 with the same result a RMA was issued and I was ready to ship the wheel out. While I was testing this, with the blue led in the driver properties still constantly lit. I got a phone call and had to get out of the rig and step away from that PC for maybe half an hour or so. When I came back the blue light was OFF!! It stayed off when using the shifter as well.

    Now, I have never seen a piece of electronics going from one state of failure to the opposite state of failure while nobody is touching anything. That had to be a mechanical issue.

    I decided to inspect the wheel more closely and after some discussion with myself, I removed the pin which holds the shifter in place. With the right tools it is easy and does not leave a mark behind - if you are concerned about the warranty: DO NOT DO THIS.

    I lifted the shifter out and sure enough there are two rubber feet glued to the shifter and the right one was almost completely off. To make matters worse some tiny rubbery glue residue had dropped down onto the gap where the other rubber stamp sits in the plastic retainer jamming the mechanism. Here is a video from a guy removing the shifter and it shows the bits and pieces I am talking about: Easy Fix for LOUD shifters on the Fanatec Mclaren GT3 V2 Wheel - YouTube

    You can also see those rubber feet in that video are misaligned, so sooner than later he will have the same issue.

    I have notified Fanatec about my findings and suggested to use a different glue. The glue used is really rubbish and not up to the job.

    I cleaned the entire area thoroughly, removed the rubber feet and all glue as well. Glued with UHU Por (stays flexible, does not dry brittle) and let it sit for 24 hours. Put the shifter back in and it is good as new.

    Shifter works again as it should.


Sign In or Register to comment.