Driver will not detect either my PS4 F1 steering wheel or my R300+BME


I am hoping you can help me with my issue because I feel like I have tried everything.

I have the Podium Racing Wheel F1 bundle with v3 pedals and shifter. The first time I set it up, it worked like a charm. I downloaded the driver from the website and it detected the wheel and I was able to flash the latest update onto the wheel. Fast forward two weeks and I take delivery of the R300 wheel with advanced paddles and Button Module Endurance (BME). When I try to plug and play onto the base, the BME turns on but nothing is detected, cant adjust anything. I then connect the wheel to the PC to flash the latest software and the driver now will not detect ANY wheel on the base. It will not detect the new R300+BME or the F1 steering wheel that I had previously flashed. All I see is what I attached on an image. No matter what I do, it will not detect either steering wheel now. The F1 steering wheel is still playable on PS4 as usual per the first flash that I was able to do. But not the R300, it turns on but that is it, nothing more. I repaired, uninstalled then installed, nothing changes. I tried downloading latest driver 356 and nothing. I tried running the first driver I downloaded, and nothing. I do not know what to try now and I am hoping you can help me, please let me know what I can answer for you to help me out.

Oh and when I do click on the controller that is shown, all it lets me do is some calibration of axis es. That is all.

Again, thank you.


Sign In or Register to comment.