Fanatec DD2

Good morning all,


I am coming to you because I have a problem with my Fanatec DD2.

When I am racing on Iracing in the middle of a straight line or in a turn the steering wheel gives a sudden force to the right or left on its own and sometimes I can control the car and often I go into the wall.

Can you tell me if anyone has ever had this problem?


Thank you in advance for your answers.


Eloi.

Comments

  • oscillations.

    increase these in various ratios:

    dampening, friction, and interpolation

    Lower:

    FEI


    getting it dialed in just so is an art, try stating with the iracing settings in the forum. Dampening is the most effective tool, but it masks feedback in general, so use as little as you need to calm the wheel down.

  • Hello,

    I have uninstalled Fanalab and no more steering wheel problem for now.

    The DD2 works perfectly now.

    Eloi.

  • It’s a known issue for 1,5 year called jolts and these will happen when you have telemetry data enabled or displaying anything other then the default Fanatec logo on the screen.

    Good thing is that you can prevent it by just letting the screen on the Fanatec logo and disable ITM features.

    Bad thing is that it’s a known issue for 1.5 year and there has been zero to none progress on solving it so far (at least Fanatec isn’t saying anything about it). So basically every DD1/2 user has paid for a feature that is absolutely useless because when using it will negatively effect the performance of the wheelbase and there is no known timeline on when en how they are going to fix it.

  • Hello Reind,

    so does the problem come from fanalab?

    What exactly should I do to remove the problem?

    Thank you for your answer.


    Eloi

  • No the issue doesn’t come from Fanalab, it’s firmware related.

    only thing you have to do is NOT using the ITM feature or use one of the info displays. Just make sure the display on the wheelbase is displaying the Fanatec logo.

    And then enjoy a jolt free DD witch an awesome display.... that doesn’t do a thing but could be an awesome feature if it did how Fanatec advertised it on the product page of this premium product.

  • Hello Reind, Thank you very much for your information which allowed me to make the shaking disappear.

    But now Fanalab stops by itself when I launch a game.

    I disabled the ITM option in fanalab and the base.

    Do you think it could come from there?


    Thank you in advance for your reply.


    Eloi

  • Disabling in Fanalab should be enough, not sure why it closes itself... that shouldn't be happening and definitely shouldn't be related to the ITM settings.

    What you could do is download the profiles Maurice made and pick the one that you need after extracting, load it into Fanalab and see what happens (ITM is disabled in those profiles, at least the one i used as a starting point for my own profiles).

  • edited February 15

    hmmm I thought they had ITM disabled, been a while since I used them for my own profiles... probably mixed them up with my own exports then.

    @eloi I’ll export one of my profiles for you later today so you can check if that helps.

Sign In or Register to comment.