Is my CSW2.5 faulty?

I recieved my 2.5 3 days ago, downloaded and installed the latest drivers and fanalab, but couldnt detect the unit at all. So I went into bootloader mode like it said to and updated the firmware, it restarts but then just sits there with a blinking (full) red start light. I've tried every usb port and the other driver they had on the site (381 i think) but to no avail and so I submitted a support ticket, but thought I'd try here too. Since friday I have found out I can get the wheel to fully power on but only by wiggling the steering column back and forth or slowly turning back and forth (otherwise just a blinking red start light). The light goes solid red and my WRC wheel (when plugged in) starts blinking cal, so I found the button combo to do that, but it never auto-calibrated like my old wheel did it just sat there with the fans going full out. Windows detected it now that its fully on and I opened the firmware manager heres what it said:

CSW 2.5 = 684

V2.5 Motor = 0


CSL Pedals LC = 1.9

Now if I try and update it the firmware manager says it'll update the motor firmware, but after about 2-5 minutes it throws an error message up stating:

A problem has been encountered while starting Update mode (0).

Please contact fanatec support for help.

So I did, I even tried calling but all I got was a busy signal (several times this mornin). So I'd like any help anyone could give, as I havent managed to accomplish anything past that yet. It senses the wheel turning in the tuning menu, lights up the LEDs and segmented display but no ffb. Thanks for reading, any suggestions?

I was so excited when they came...


  • You don't need to set anything in bootloader mode, probably it wasn't detected because it was in Xbox mode. Normally you just connect it to the pc (make sure the base is in PC and not Xbox mode also), fire up the update manager and you should be good to go regarding firmware management. At least that's how i did it a few months ago (the new firmware manager wasn't released then).

    So i'm not sure you followed the right procedure when it come to updating the wheelbase.

  • Thanks for the input, that was one of the first things I checked (nope in pc mode). Also the Driver instructions said to update the firmware, but since I couldnt get it to power up(just flashing a full red start ring) that seemed the next logical step. The instructions even mention that its one of 3 ways to update the wheel base so I would think it would be fine. I was / am more confused as to why it just flashes the red start ring at me and wont 'turn on' unless I turn the wheel slowly back and forth, never heard of that happening. Anyway thanks for the help I hope everyone's having a good day ;)

  • Update: I called and they gave me an rma # so now off to figure out shipping. Have a good day everyone, and thank you.

Sign In or Register to comment.