Clubsport 2.5 wheel base no longer recognizing wheel

The wheel base (Clubsport 2.5) seems to think there is no wheel (Clubsport Forza Motorsport) attached to it. I did a firmware update and a driver update today after not using the wheel for a few months. Now the "Fanatec Wheel Properties" dialog is reporting that no wheel is attached to the base and shows a big red cross over where the wheel should be. The power button on the base is has a single red segment that is "spinning" around. None of the buttons on the wheel are responsive and the small screen on the hub is not on.

I've tried powering off and on the device a few times. Starting it with and without the wheel attached. I also tried a couple different driver versions, no combination seems to work.

Anyone else had this issue? How did you get it resolved?


  • Did you already installed the latest driver / firmware, the one in your picture displays v381 while v402 is the latest version.

  • Hello! I have the same problem even after installing 402 drivers. i have csw2.5 and podium hub. can you help me? thank you

Sign In or Register to comment.