CSL Elite Pedal suddenly not responding

I've been using the CSL Elite Pedals with Loadcell kit, and everything worked fine for about a month or two. Suddenly today, I got onto PC2 and everything worked except the throttle. The brake, clutch, steering wheel, shifter, etc, all worked fine. But the throttle wasn't. I backed out and went to the Fanatec calibration program and confirmed I have updated software. What is really weird is that the other two pedals respond and can be calibrated, but there is NO feedback from the throttle. I currently have the pedals plugged into the base. When it's plugged in like that, I get no feedback from throttle. If I plug the pedals directly into the PC via USB, and UNPLUG the base USB, I get response from the throttle. But if I plug the base back into the PC (with the pedals in via USB) I all of a sudden lose my throttle again. It isn't picking it up at all. This is really buggy, and I had not touched any of the hookups otherwise. Any ideas?

Sign In or Register to comment.