CSL Elite F1 Not Recognizing Pedals

OK I'm tearing my hair out trying to get this working.

Got the bundle with Load Cell kit yesterday. Swapped out pedal controller to load cell one. Connected pedals to controller, connected RJ12 cable from pedal box to back of wheelbase, connected wheelbase to computer to update the drivers. Updated to driver 402. Within the Fanatec software that installs when you plug the pedals in, I don't see the throttle or brake inputs. When I connect to my PS5 it does not recognize the pedals. I tried flipping the RJ12 cable around (swapping ends) and this does not work. I tried connecting the original CSL Elite pedal box and pedals, still doesn't register anything.

When I connect the pedals via USB (with the RJ12 connecter UNPLUGGED) to the PC it let me update the driver for that also, and it registers the pedal input pressures. Connect the pedals to the wheelbase and now I have no inputs.

Full disclosure, I use a folding cockpit, and I accidentally pulled the power cable out of the back of the wheelbase when the pedal deck was unfolding. This slightly damaged the end of the power cable (little yellow plastic part). I highly doubt this has anything to do with my problem but just thought I should note it.


  • Guessing you might have damaged the wheelbase RJ12 socket

  • SOLVED: Sort of. For some reason the pedals only register when you push the RJ12 cable into the wheelbase with some force and hold it there. As soon as I let go the pedals don’t work. I ziptied the cable down in such a way to add a little bit of pressure (nothing crazy, as if you’re pushing it in with one finger) and it is working. I’m going to order a new cable and see if that works. If not then it’s a problem with the actual connector on the wheelbase.

  • The power socket and the RJ12 socket aren't next to each other, I don't think I damaged it when the power cord got pulled out.

Sign In or Register to comment.