Brand New CSL Elite + (PS4) and McLaren GT3 v2 Dead Out Of The Box?

Hi all,

I literally just unboxed my CSL Elite + PS4 version, installed the drivers on my PC, plugged in the wheelbase, updated the firmware, and when it told me to attach the wheel nothing happened. The screen didn't light up with the Fanatec Logo on the McLaren GT3 v2, and the wheelbase didn't recognize that the wheel was even installed.

Then, later when I re-opened the Game Controller properties for the CSL Elite, I get a message that says, "The attached Steering Wheel is not supported by the currently installed Wheel Base firmware!" which is interesting because when I click OK, it says I'm on driver 400 (also tried with 402) and the firmware is 684 with a motor firmware of 22. Pretty sure I'm up to date there.

Anyone have any ideas? I've tried uninstalling/reinstalling, older drivers that work on friends setups with the V2 wheel, driver 402 and the related firmware, removing all of the logitech stuff on my system, and numerous restarts all to no avail. How likely is it to get a DOE base or rim?


Sign In or Register to comment.