Formula V2 Rim button Failure on a DD2 base

I'm having a complete nightmare where my buttons on my wheel just fail, suddenly I cant shift up or down, to be honest if it was just the other buttons I could probably manage, but losing the shifters its absolutely killing me, I've just had it fail 5 times in the space of 1 hour during a 3 hour race. I'm starting to dread every time I go to use it and change gear.

It was a problem that started the end of last year, so I was told to update firm wear and check connections of which I have, I was also told it could be current interference from the power cable so I've made sure my power cable is nowhere near the others, I also use to run a usb power hub for the led lights, webcam and a few other little things so disconnected that, (the DD2 has always been connected directly into my PC) I've even earthed my rig. It's been fine for a few weeks then last night it decided to come and haunt me, then today was just a total disaster with multiple failures.

The pins are all solid in the back of the wheel, one of them is shorter than the rest, but I've been informed that's normal. I still have FFB, and steering but just no functions. I've found the fastest way to resolve it so far it to pull of the wheel and reconnect it, but of course this is risky and costs me about 10 seconds.

Has anyone else experienced this and how did you manage to resolve it?


Thank you

Adam Christodoulou

Comments

  • I have the exact same issue with my clubsport v2.5 wheelbase and v2 rim.

    It started a week ago and happend 3 times since. Not 5 times in one hour but it happend.

    You found a solution yet?


    I hope you do!


    Grtz niels

  • edited March 16

    Well, at least I am not alone. I started having this problem for almost 2 weeks now, so basically the same as you guys. My wheel would disconnect and say 'Caution - please update firmware" even though my firmware is all up to date. I have a csw 2.5, csp v3 & cs formula v2 rim.

    All I could do really is try to make it more stable - I found that going to an older driver has helped a little bit but it is still a pain. Missing gears, not picking up on buttons at certain points (the light at the bottom of the wheel shuts off and the Fanatec logo shows up a bunch.)

    Other times it will completely cutout or disconnect completely.

    Feels like I have a defective wheel as I have tried all the same troubleshooting as well as tightening screws inside the quick release of the wheel and wheel base (the middle ones were a little loose so I moderately tightened them.

    This has been getting frustrating and it is even more frustrating how hard it is to try and get in touch with Fanatec. When I try to create a support ticket for my Clubsport rim, it does not allow me to submit it (just says new support ticket and all my info gets erased. My best best was to send an email to customer serivce so hopefully I heard back by the end of the week.

    I have some videos of my issues - it was pretty hard to take a video of me playing with a phone lol I had to keep myself so still. I am unable to share them with Fanatec as of yet because the support ticket system on the website is quite confusing and seems to go in a never-ending loop. I have tried 3 browsers as well as clearing cache on a fairly new pc that is up-to-date.


    I hope we all find a solution to this as I am sure you are as frustrated as I am.

Sign In or Register to comment.