Fanatec Jan 2021 Driver Update - Podium racing F1 steering wheel not working anymore !!

Installed Fanatec 400 driver January 2021 and my problems started !

It worked fine after the installation and was able to play GT Sport in PS5 console flawlessly.

The issues started after the first restart.

Here is what happens no matter USB is connected to console or not.

  1. DD starts and flashes the display
  2. Steering wheel rotates just like usual start
  3. All at a sudden display goes blank on both steering & DD
  4. You can hear rumble motors inside steering wheel and nothing happens.

While connected to PC - Windows 10 Home

I can see firmware popup and repeated firmware flashing on a loop and above steps in 1 - 2 - 3 - 4 again and again !!

Raised support ticket and god know when fanatec will reply.

After repeated restarts - It worked once - I was able to play gtsport. After the off and on - Same problem again. This time restarts are not helping.


If i disconnect the steering wheel - DD display comes back but the moment i connect the steering wheel - Display goes blank and rumble motors inside steering wheel comes alive. While connected to PC - Repeated flashing of firmware observed !!


Help Please !!!

Comments

  • Hi Anil,

    I'm sorry to hear about this, but based on what you have tried so far, it's not something that can be resolved via the forum.

    Support tickets are currently being responded to within 2-3 working days, so I'm sure you will receive a reply soon.

    To be honest, it sounds like the issue you're experiencing is not related to the new driver package.


    [Fanatec Community Manager]

  • edited March 29

    Ditto! All this just started for me today. DD1 and Formula V2 (PS4) version. I was playing iRacing and the paddle clutches stopped working and the rumble was always on (at least while stationary when it was really noticeable). Restarted everything and now whenever the DD1 starts up it drops straight into a firmware update for the rim. Cannot get out of the loop.

    I guess I'll send an email to support for a 3 day reply but if you get a solution please post it!


    Scott.

  • Another to be added to the V2 Formula DD1 unresponsive buttons.

    I’m getting exactly the same issue as Scott above.

    Ugh. And this was supposed to be the Fanatec product that wouldn’t fail!

  • It's still the same !!!

  • Fanatec Team, Please help,

    The real issue is F1 wheel going into repeated flashing firmware after the driver update :(

  • Scott , Tony - Have you received any updates from Fanatec ?

  • edited April 15

    New Fanatec customer and I just purchased and connected the following after completing my 8020 rig.

    1. DD1

    2. Podium Hub

    3. Podium paddle module

    4. Podium button module

    5. Porsche 911 GT3 wheel

    6. Shifter SQ v1.5

    After connecting everything I was prompted to do firmware upgrades. I was able to get the DD1 (both base and motor) and Quick Release firmware upgraded without issues but having issues when I connect my wheel. The upgrade for Podium Hub goes into a loop. Have you all seen this issue? I've tried everything - downgrading firmware, plug into different USB port, uninstall drivers. Frustrated and just wanting to get some racing in before I'm off on travel for work...


    I put a Support ticket in a few days ago and no response yet. Waiting for 2 - 3 business days for a response.



  • Not sure if it is going to work but could you try to uprate the podium hub without the Button module being connected (disconnect the mini usb underneeth) ?

  • Yes I tried that too! Still getting the same issue. Thanks tho.

Sign In or Register to comment.